This is very unfriendly and with just a little bit extra thought and effort could be so much improved.
Circle(double d, double d1, double d2, Paint paint)
There are many other examples with the api that would also, so easily benefit from a little more attention. You may well say that its not really important and that the functionality is far more important and further suggest that I stop moaning, but it is important and you are only letting yourselves down.
Circle(double centerX, double centerY, double radius, Paint fill)
i.e. the exact same naming scheme you are suggesting.
public Circle(double centerX, double centerY, double radius, Paint fill)