2 Replies Latest reply on Jan 3, 2013 12:40 PM by SHAN2009

    OMS is not set up for Enterprise Manager Security - Oracle 10G Grid Agent

    SHAN2009
      Hello Everyone,

      Good Day ......

      While secure the agent i am facing an issue. Below are the error message i am getting from the secure.log file.

      If you have any idea what could be the problem why the secure it not happening please help and advice me to resolve this issue.

      Error Message:

      Agent Version : 10.2.0.5.0
      OMS Version : 10.2.0.5.0
      Protocol Version : 10.2.0.5.0
      Agent Home : /rdbms/agent10g/agent10g
      Agent binaries : /rdbms/agent10g/agent10g
      Agent Process ID : 2539
      Parent Process ID : 2494
      Agent URL : http://bbcatom:3872/emd/main/
      Repository URL : http://zeo.uk.com:1159/em/upload
      Started at : 2012-12-24 12:51:59
      Started by user : oracle
      Last Reload : 2012-12-24 12:56:51
      Last successful upload : (none)
      Last attempted upload : (none)
      Total Megabytes of XML files uploaded so far : 0.00
      Number of XML files pending upload : 101
      Size of XML files pending upload(MB) : 24.35
      Available disk space on upload filesystem : 65.76%
      Last attempted heartbeat to OMS : 2012-12-24 15:53:23
      Last successful heartbeat to OMS : unknown
      Oracle Enterprise Manager 10g Release 5 Grid Control 10.2.0.5.0.
      Copyright (c) 1996, 2009 Oracle Corporation. All rights reserved.
      Stopping agent ... stopped.
      [24-12-2012 15:53:27] USERINFO ::Agent successfully stopped... Done.
      [24-12-2012 15:53:27] USERINFO ::Securing agent... Started.
      2012-12-24 15:53:38,159 [main] INFO agent.SecureAgentCmd secureAgent.223 - Requesting an HTTPS Upload URL from the OMS
      2012-12-24 15:53:38,344 [main] ERROR agent.SecureAgentCmd secureAgent.228 - The OMS is not set up for Enterprise Manager Security.
      2012-12-24 15:53:38,346 [main] ERROR agent.SecureAgentCmd main.207 - Failed to secure the Agent:
      java.lang.Exception: The OMS is not set up for Enterprise Manager Security.
      at oracle.sysman.emctl.secure.agent.SecureAgentCmd.secureAgent(SecureAgentCmd.java:229)
      at oracle.sysman.emctl.secure.agent.SecureAgentCmd.main(SecureAgentCmd.java:200)

      Thanks & Regards,

      Shan.....

      Edited by: SHAN2009 on Dec 27, 2012 1:49 PM