This discussion is archived
2 Replies Latest reply: Dec 27, 2012 12:13 AM by 920719 RSS

Issue with LOV in form

920719 Newbie
Currently Being Moderated
Hi Friends,
I am having a peculiar problem with the LOVs in forms.

I have two blocks A and B. In block A I have a couple of items I1 and I2 which have LOVS and both the items are mandatory. When we select I1 I2 gets populated as well. The value in the I2 is perfectly valid. Both the items have the property "Validate Items in the List" No.

However when I go to the next block B after selecting I1 The value in I2 is getting deleted(I1 is not getting deleted) and the cursor goes back to I2 since it is mandatory. I am selecting the value of I2 again and then when I go back to Block B it works. There are only two values that get populated I1 and I2.

I am working on Oracle Forms 10g. Ebiz suite version is 12.1.3

Can someone help how to resolve this.

Thanks
  • 1. Re: Issue with LOV in form
    Srikkanth.M Pro
    Currently Being Moderated
    Hi,

    First thing you have two block A and B and four different field.

    If yes.

    Second thing if its a dependent parameter for example If you select the L1 supplier name and L2 Supplier site is populated..

    Third thing you need to Check how many LOV you have created for this Four Fields.If you have created two its wrong. Create Four Different LOV and attach to the fields and check it now works.


    Thanks & Regards
    Srikkanth.M
  • 2. Re: Issue with LOV in form
    920719 Newbie
    Currently Being Moderated
    Srikkanth,
    I created 4 different lovs and this works now.

    Thanks

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points