11 Replies Latest reply: Dec 27, 2012 3:57 AM by user11978217 RSS

    Calculation Manager not opening

      Calculation Manager is not opening. When i try to open Calculation Manager through workspace it gives the following errors.

      "Invalid or could not find module configuration."

      "Required application module calcmgr.filterview is not configured. Please contact your administrator."

      "Namespace Communication Error"

      and this is what is shown in details,

      "URI: http://hptstorg:19000/calcmgr/conf/CalcMgrConfig.xml

      Parse Error, XML Returned:
      <TITLE>Weblogic Bridge Message
      <H2>Failure of server APACHE bridge:</H2><P>
      <hr>No backend server available for connection: timed out after 10 seconds or idempotent set to OFF.
      <hr><BR><B>Build date/time:</B> <I>Oct 27 2009 13:34:24</I>
      <P><HR><B>Change Number:</B> <I>1013</I>
      OKHide Details"

      I tried restarting the server, after restarting it opens the calculation manager but hangs when we try to open the list of rules. after force quit when 1 try to run calculation manager again it gives the above errors.

      I have open shared services and it works fine but dimension library gives error while opening.

      This issues starts after cloning of an application.

        • 1. Re: Calculation Manager not opening
          Have you checked the calculation manager logs?


          • 2. Re: Calculation Manager not opening
            Yes i have but really don't understand these log much. This is what last 4 lines says.

            <Dec 17, 2012 5:17:49 PM GMT+05:00> <Notice> <WebLogicServer> <BEA-000358> <Started WebLogic Independent Managed Server "CalcMgr0" for domain "EPMSystem" running in Production Mode>

            <Dec 17, 2012 5:17:49 PM GMT+05:00> <Warning> <JMX> <BEA-149510> <Unable to establish JMX Connectivity with the Adminstration Server AdminServer at <JMXServiceURL:null>.>

            <Dec 17, 2012 5:17:49 PM GMT+05:00> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to RUNNING>

            <Dec 17, 2012 5:17:49 PM GMT+05:00> <Notice> <WebLogicServer> <BEA-000360> <Server started in RUNNING mode>
            • 3. Re: Calculation Manager not opening
              Check this document on Oracle Support

              Error while opening Calc Manager from Workspace [ID 1320364.1]

              Please mark answers as helpful or correct for others to find them easily

              Edited by: hyperionEPM on Dec 17, 2012 8:31 PM
              • 4. Re: Calculation Manager not opening
                I have checked the SR. I have checked this url http://servername:19000/calcmgr/conf/CalcMgrConfig.xml and this shows me "calculation manger". So the issue should be with user name according to the SR. But the user is not expired and still i altered the user and unlocked it but the issue remains. I tried to reconfigure the calculation manager using EPM system Configurator. But i think i have messed it up. Now http://servername:19000/calcmgr/conf/CalcMgrConfig.xml doesn't show calculation manger. I ran EPM diagnostic test, and a lot of things gave errors, all are ora-12519 TNS: no service handler found.

                Waiting for help. Regards.
                • 5. Re: Calculation Manager not opening
                  When you say you reconfigured Calc Manager which components did you reconfigure in the configurator? If you are getting TNS errors then there is something wrong at the Oracle database level or the information provided to the EPM database configuration is incorrect.


                  • 6. Re: Calculation Manager not opening
                    If you reconfigured CM then you should also reconfigure and restart the web server. A really simple way to check if CM is working is logging into weblogic admin console. You need to start the admin server first... you'll find both shortcuts under weblogic in start menu if you're running it on Windows.

                    • 7. Re: Calculation Manager not opening
                      Here this is what i have done. I opened EPM system configurator. under hyperion foundation i just checked calculation manager (not the components under it). on clicking next this table comes      

                      Hyperion Foundation     
                      Calculation Manager     

                      again on clicking next the configuration was done.

                      Then i selected configure database and configured it. But when i select deploy to application server and try to configure it, it ask me to change the ports. I tried to change but it won't accept any. So i left it.

                      I stopped and started the epm system and when i tried to run epm system configurator again. It asks to update my applications. I choose all applications and started the update. I have no clue what i have done.

                      Later today the issue still remains. I have figured why name space and other error comes because i don't wait for calculation manager to start properly. if i open calculation manager 5 mins after stopping and starting calc manager service. The actual post error won't come.

                      (This is the actual problem i am facing)

                      But when i expand planning in calculation manger an error comes saying
                      "Could not connect to Dimension Server.
                      Please make sure that the required services are started."
                      Then i expand my application and plan type and rules, it hangs on rules showing that it will load the rules soon. But it never does.

                      thank you for bearing me, waiting for reply, regards
                      • 8. Re: Calculation Manager not opening
                        I have searched for the ora-12519 issue and TNS issue. Some people say that it occurs because the no. of process allowed by oracle database exceeds the limit. I have checked it. The total no. of process allowed are 150 and the current running process are 145-148. Could it be possible that this error is coming due to this?
                        • 9. Re: Calculation Manager not opening
                          So are you now saying Calculation Manager works, if there are no errors in the logs when it starts then it should be ok.
                          If it says it can't connect to the dimension server that means there an issue on the EPMA side.


                          • 10. Re: Calculation Manager not opening
                            Now the EPMA services are not starting. I have raised an other thread EPMA services not starting up asking about EPMA services issue. But before these EPMA services are running. I guess that trying to reconfigure calc manager had done some thing bad and now EPMA services are not starting.
                            • 11. Re: Calculation Manager not opening
                              The issue has been resolved.

                              Cause - The Calc Manager service was starting up but was taking a very long time due to that fact that there were over 14,000 rules in the CALGMGRRULES table, and at startup time these were all being loaded into cache.

                              Reduce the number of rules that need to be loaded into memory, by deleting any unused rules via Calc Manager.

                              1. Stop the Calc Manager service.

                              2. Take a backup of the Calc Manager database.

                              3. In order to access Calc Manager, disable the pre-loading of the cache by editing the following file under the Calculation Manager web application deployment:

                              C:\Documents and Settings\Administrator\Local Settings\Temp\1\Administrator\servers\CalcMgr0\tmp\_WL_user\CALC_11.1.2.0\qxf61x\war\WEB-INF\conf\CalcMgrConfig.properties

                              adding the following entry:

                              4. Startup the Calc Manager service.

                              5. It should now be possible to access Calculation Manager. Review the existing rules. If there are any applications that are not currently being used, delete all of the rules for that application.

                              6. Once the number of rules has been considerably reduced, the PRELOAD_CACHE property should be removed from the CalcMgrConfig.properties file.