This discussion is archived
5 Replies Latest reply: Dec 27, 2012 9:31 PM by adf_user RSS

Cannot find pubsub-1.0.war in wlserver_10.3

adf_user Newbie
Currently Being Moderated
Hi,
Version: JDeveloper 11g (11.1.2.3.0)

I was unable to find pubsub-1.0.war in jdev bundled weblogic server in the path: wlserver_10.3\common\deployable-libraries.



Appreciate if anybody can direct me towards this library.


Thanks!!!
  • 1. Re: Cannot find pubsub-1.0.war in wlserver_10.3
    adf_user Newbie
    Currently Being Moderated
    Any hints? Or do I need to ask this in any other category in this forum.
  • 2. Re: Cannot find pubsub-1.0.war in wlserver_10.3
    Timo Hahn Oracle ACE
    Currently Being Moderated
    Looks like this war is not bundled in this version. You hands to remember that the 11.1.2.x version is not complete but a preview for jsf 2.0.
    Look for the war in an 11.1.1.x installation.

    Timo
  • 3. Re: Cannot find pubsub-1.0.war in wlserver_10.3
    adf_user Newbie
    Currently Being Moderated
    Thanks for your reply Timo.
    I could not get my hands on the 11.1.1.x version, so I had to install the standalone version of wls which contains the war file.

    Just out of curiosity, I was trying to implement the PubSub example as outlined in http://docs.oracle.com/cd/E24329_01/web.1211/e21049/pubsub.htm.
    But as the integrated server did not contain the war file nor does it contains the required libs (com.bea.core.http.pubsub.*), does this mean I've to configure the standalone server in Jdev to make it work?

    Thanks..
  • 4. Re: Cannot find pubsub-1.0.war in wlserver_10.3
    Timo Hahn Oracle ACE
    Currently Being Moderated
    I'm not sure the embedded wls had the ear file included. The sample you try to run is for wls 12c, so it's no wonder that you have problems running it on your 11.1.2.3 jdev.
    Of the war I'd not past of the embedded wls you have to set up the need libs too.

    Timo
  • 5. Re: Cannot find pubsub-1.0.war in wlserver_10.3
    adf_user Newbie
    Currently Being Moderated
    Hello Timo,
    Yupp, The embedded wls does'nt contain the ear/war/jar files. As far as the sample for 12c in the docs, I only took the neccessary parts and tried in my jdev version.
    Steps I followed:
    1. Copied the pubsub-1.0.war file from standalone wsl to Jdev integrated server.
    2. Copied all the required jars to "modules" folder inside wlserver_10.3. (Also the jars inside "features" folder).
    3. Through weblogic admin console, deployed the pubsub war as a Library.
    4. Deployed my sample webapp. And it started without any exceptions in the log.

    The only issue is that the below pubSubServer always returns null no matter what "serverName" I had specified.
    PubSubServer pubSubServer = pubSubServerFactory.lookupPubSubServer(serverName);

    Anyways, I'll look onto it and let you know and thanks again for you reply.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points