This discussion is archived
4 Replies Latest reply: Mar 26, 2013 10:29 AM by venkata thiruveedhi RSS

Authentication Failed at login to EM12c but able to login via SQLPlus

616017 Newbie
Currently Being Moderated
I am able to log into my database via SQLPlus as SYSTEM but unable to log into Enterprise Manager 12c Cloud Control with the same user. I am received an "Authentication Failed" message. What's going on?
  • 1. Re: Authentication Failed at login to EM12c but able to login via SQLPlus
    899308 Newbie
    Currently Being Moderated
    Cloud Control has 2 level authentication. You first log on to EM and then separately to the target database. For the initial connection to EM, the EM admin has to create an EM user who is separate from the target db user. Once you have been authenticated to EM, you can then logon to the db as SYSTEM user.

    -Mughees
  • 2. Re: Authentication Failed at login to EM12c but able to login via SQLPlus
    616017 Newbie
    Currently Being Moderated
    I think my real problem start with the inability to start the OMS service (from emctl.log). Not sure what to do next:

    012-12-28 12:22:56,854 [main] DEBUG wls.OMSController main.197 - Log location is F:/app/wls/middlewear/gc_inst/em/EMGC_OMS1\sysman\log\emctl.log
    2012-12-28 12:22:56,854 [main] INFO wls.OMSController main.204 - Executing command:start
    2012-12-28 12:23:02,111 [main] ERROR oms.StatusOMSCmd processStatusOMS.321 - Connection exception when trying to hit OMS page. OMS is down
    2012-12-28 12:23:02,111 [main] INFO commands.BaseCommand statusOMS.377 - statusOMS finished with result: 8
    2012-12-28 12:23:02,111 [main] INFO commands.BaseCommand execute.64 - currStatus is 8
    2012-12-28 12:23:02,111 [main] INFO commands.BaseCommand startOMS.162 - admin start is false
    2012-12-28 12:23:02,111 [main] INFO commands.BaseCommand startOMS.163 - is service is false
    2012-12-28 12:23:07,197 [main] ERROR oms.StatusOMSCmd processStatusOMS.321 - Connection exception when trying to hit OMS page. OMS is down
    2012-12-28 12:23:07,197 [main] INFO commands.BaseCommand statusOMS.377 - statusOMS finished with result: 8
    2012-12-28 12:23:07,197 [main] INFO commands.BaseCommand getEnvProps.431 - nm home replaced : F:/app/wls/middlewear/gc_inst/NodeManager/emnodemanager
    2012-12-28 12:23:07,212 [main] INFO commands.BaseCommand getEnvProps.446 - Setting trust store system properties: -Dweblogic.security.TrustKeyStore=DemoTrust -Dweblogic.security.SSL.ignoreHostnameVerification=true -Djava.security.egd=file:///dev/./urandom
    2012-12-28 12:23:07,212 [main] INFO commands.BaseCommand startOMS.335 - Issuing net start for oms service...
    2012-12-28 12:23:07,244 [Thread-2] INFO commands.BaseCommand run.554 - <ERR>System error 5 has occurred.
    2012-12-28 12:23:07,244 [Thread-2] INFO commands.BaseCommand run.554 - <ERR>
    2012-12-28 12:23:07,244 [Thread-2] INFO commands.BaseCommand run.554 - <ERR>Access is denied.
    2012-12-28 12:23:07,244 [Thread-2] INFO commands.BaseCommand run.554 - <ERR>
    2012-12-28 12:23:07,244 [main] INFO commands.BaseCommand processCmd.487 - wlst process is finished
    2012-12-28 12:23:07,244 [main] INFO commands.BaseCommand processCmd.489 - wlst process exited with code 2
    2012-12-28 12:23:07,244 [main] INFO commands.BaseCommand processCmd.491 - wlst outstream joined
    2012-12-28 12:23:07,244 [main] INFO commands.BaseCommand processCmd.493 - wlst errstream joined
    2012-12-28 12:23:07,244 [main] INFO commands.BaseCommand processCmd.499 - process exited with code 2
    2012-12-28 12:23:07,244 [main] INFO commands.BaseCommand startOMS.341 - net start return code is 2
    2012-12-28 12:23:07,244 [main] ERROR commands.BaseCommand startOMS.344 - Windows service OracleManagementServer_EMGC_OMS1_1 failed to be started
    2012-12-28 12:23:12,392 [main] ERROR oms.StatusOMSCmd processStatusOMS.321 - Connection exception when trying to hit OMS page. OMS is down
    2012-12-28 12:23:12,423 [main] INFO commands.BaseCommand statusOMS.377 - statusOMS finished with result: 8
  • 3. Re: Authentication Failed at login to EM12c but able to login via SQLPlus
    Facundo Newbie
    Currently Being Moderated
    Hello, Can you solve this issue? if yes, could you explain the solution?

    Thanks.
  • 4. Re: Authentication Failed at login to EM12c but able to login via SQLPlus
    venkata thiruveedhi Guru
    Currently Being Moderated
    Hi,

    Check the following document:

    12.1.0.2 : Login to Console Fails With "Authentication failed. If problem persists, contact your system administrator." (Doc ID 1493151.1)

    Regards,
    Venkat

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points