1 Reply Latest reply: Dec 28, 2012 2:01 PM by user4147906 RSS

    Error ERR-7620 and ERR-7621

    user4147906
      Hello,

      After upgrading Apex 4.0.1 to 4.1.1 and adding Oracle Access Manager authentication (see http://www.oracle.com/technetwork/developer-tools/apex/learnmore/apex-oam-integration-1375333.pdf), an error occurs when an OAM session is disabled, expired, or terminates. Once the OAM session terminates, the Apex user is presented with OAM login, as expected. But after login one of the errors below occurs:

      Error ERR-7621 Could not determine workspace for application (:) on application accept.

      Expecting p_company or wwv_flow_company cookie to contain security group id of application owner.

      OK

      or

      Error ERR-7620 Could not determine workspace for application ().

      Expecting p_company or wwv_flow_company cookie to contain security group id of application owner.

      OK

      Clicking OK brings the user back to the original page in IE. In Firefox the user is presented with another login page, and then an error, because the user is already logged in. User must then manually find their way back to the application page.

      Does anyone know how to workaround this? I've tried setting the Application session timeout values to be slightly less than OAM timeout values, thinking that a graceful logout from Apex will resolve the error, but the error still appears.

      --J                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
        • 1. Re: Error ERR-7620 and ERR-7621
          user4147906
          The error can be repeated by clearing browser cookies as well. Does anyone know why cookies, containing the security group id, would get getting mangled or removed? Is there anyone out there who is successfully using OAM (HTTP header authentication) for Apex authentication?

          Edited by: user4147906 on Dec 28, 2012 12:01 PM