10 Replies Latest reply: Jan 2, 2013 6:28 PM by Srini Chavali-Oracle RSS

    Oracle Installer:[INS-13001] Environment does not meet minimum requirements

    Marcelo Marques - ESRI
      Hi,

      I am trying to install the latest Oracle Database software on the latest Oracle Enterprise Linux and the installer returns "Environment does not meet minimum requirements".

      Oracle Enterprise Linux 6.3 x86-32
      Oracle Database 11.2.0.3 x86-32

      cd /stage/Oracle_Database_11.2.0.3_Linux/x86_32/database
      ./runInstaller
      1. Configure Security Updates <next>
      2. Download Software Updates <next>
      Get the warning screen with the error,

      Oracle 11g Database Release 2 Installer:
      [INS-13001] Environment does not meet minimum requirements.
      Are you sure you want to continue ?

      I looked the log file but it didn't tell much.

      cd /tmp/OraInstall2012-12-15_04-26-04PM
      tail installActions2012-12-15_04-26-04PM.log
      ...
      INFO: Verifying target environment...
      INFO: Checking whether the IP address of the localhost could be determined...
      SEVERE: CVU do not support target environment..
      Refer associated stacktrace #oracle.install.ivw.common.validator.SupportedOSValidator:371
      INFO: Completed verification of target environment.
      WARNING: Verification of target environment returned with errors.
      WARNING: [WARNING] [INS-13001] Environment does not meet minimum requirements.
      CAUSE: Minimum requirements were not met for this environment
      ACTION: Either check the logs for more information or check the supported configurations for this product..
      Refer associated stacktrace #oracle.install.commons.util.exception.DefaultErrorAdvisor:374
      INFO: Advice is WITHDRAW
      WARNING: Advised to shutdown the installer due to target environment verification errors.
      INFO: Adding ExitStatus PREREQ_FAILURE to the exit status set
      INFO: Finding the most appropriate exit status for the current application
      INFO: Exit Status is -3
      INFO: Shutdown Oracle Database 11g Release 2 Installer
      ...

      Have you seen this before?

      Thanks,
      Marcelo Marques
      Technical Manager, Esri
        • 1. Re: Oracle Installer:[INS-13001] Environment does not meet minimum requirements
          Srini Chavali-Oracle
          Pl identify how exactly you are logging in to the server. This MOS Doc may be relevant

          11gR2 Database Server install fails with [INS-13001] Environment does not meet minimum requirements [ID 1063952.1]

          HTH
          Srini
          • 2. Re: Oracle Installer:[INS-13001] Environment does not meet minimum requirements
            Marcelo Marques - ESRI
            Hi, I am physically connected to the Linux terminal. I'm not remote connected, not using a terminal, nor VNC. Thanks, Marcelo.

            Edited by: Marcelo Marques - ESRI on Dec 18, 2012 5:27 PM
            • 3. Re: Oracle Installer:[INS-13001] Environment does not meet minimum requirements
              Srini Chavali-Oracle
              Pl post the last 200 lines of the install log - http://docs.oracle.com/cd/E11882_01/install.112/e24321/app_ts.htm#i1090466

              HTH
              Srini
              • 4. Re: Oracle Installer:[INS-13001] Environment does not meet minimum requirements
                sb92075
                Marcelo Marques - ESRI wrote:
                Hi, I am physically connected to the Linux terminal. I'm not remote connected, not using a terminal, nor VNC. Thanks, Marcelo.

                Edited by: Marcelo Marques - ESRI on Dec 18, 2012 5:27 PM
                post results of following OS commands

                id
                env | sort
                • 5. Re: Oracle Installer:[INS-13001] Environment does not meet minimum requirements
                  Marcelo Marques - ESRI
                  Hi

                  I contacted Oracle support and opened a SR.

                  "SR 3-6567052611 : Oracle Installer: INS-13001] Environment does not meet minimum requirements."

                  I uploaded the RDA, because there some prerequisites might be missing.

                  RDA 4 - Health Check / Validation Engine Guide (Doc ID 250262.1)

                  Download the RDA through the below URL.

                  https://updates.oracle.com/ARULink/PatchDetails/process_form?aru=15741045&patch_password=&no_header=0

                  After it unzip the file and run the rda as below.

                  perl rda.pl -T hcve

                  Thanks, Marcelo
                  • 6. Re: Oracle Installer:[INS-13001] Environment does not meet minimum requirements
                    Marcelo Marques - ESRI
                    Hi

                    I analyzed the RDA report.

                    Result file: /u01/app/ora_rda/rda/output/RDA_HCVE_A200DB11R2_lnx_res.htm

                    The following tests FAILED.

                    "The LD_LIBRARY_PATH environment variable is set in your environment and must be unset before installing Oracle Database 11g R2."
                    [marcelo]: I tried to unset and run the database installer again, same problem.

                    'The JAVA_HOME environment variable is not set. No action required."

                    "This rule checks that the installed JDK version is JDK 5.0 update 6 or later. This is required for products like Oracle Java Database Connectivity and Oracle Call Interface drivers. "
                    [marcelo]: JDK 1.6.0_37 is installed and SQL Developer runs fine, don't understand why the RDA is picking this.
                    # ls /usr/java
                    default jdk1.6.0_37 latest

                    "The processor speed must be 2 GHz or faster. "

                    "The DNS server failed to resolve the nslookup using host.domain."
                    [marcelo]: this might be the problem, what do you think?
                    $ nslookup student03
                    Server: 8.8.8.8
                    Address: 8.8.8.8#53
                    ** server can't find student03: NXDOMAIN

                    "You have incorrect versions of binutils, compat_libcap1, compat-libstdc++-33, gcc, gcc-c++, glibc, glibc-devel, ksh, libaio, libaio-devel, libgcc, libstdc++, libstdc++-devel, make, or sysstat installed on your system. Make sure that the correct versions are installed. For the required versions, see Knowledge Article 169706.1."
                    [marcelo]: verified and the correct version of the rpms were installed, don't understand why RDA is picking this.
                    # cd /home/stage/Oracle_Enterprise_Linux_6.3/x86_32/Packages_x86_32
                    rpm -Uvh binutils*
                    rpm -Uvh compat-libcap1*
                    rpm -Uvh compat-libstdc++-33*
                    rpm -Uvh gcc*
                    rpm -Uvh gcc-c++*
                    rpm -Uvh glibc*
                    rpm -Uvh glibc-devel*
                    rpm -Uvh ksh*
                    rpm -Uvh libaio*
                    rpm -Uvh libaio-devel*
                    rpm -Uvh libgcc*
                    rpm -Uvh libstdc++*
                    rpm -Uvh libstdc++-devel*
                    rpm -Uvh make*
                    rpm -Uvh sysstat*

                    Thanks,

                    Marcelo
                    • 7. Re: Oracle Installer:[INS-13001] Environment does not meet minimum requirements
                      Marcelo Marques - ESRI
                      Hi,
                           
                      A follow up on my comments from the previous message.

                      "The DNS server failed to resolve the nslookup using host.domain."
                      [marcelo]: I don't think this is a major problem, I have installed on the same hardware OEL5 and Oracle 11.2.0.1 without problems.
                      $ nslookup student03
                      Server: 8.8.8.8
                      Address: 8.8.8.8#53
                      ** server can't find student03: NXDOMAIN

                      "You have incorrect versions of binutils, compat_libcap1, compat-libstdc++-33, gcc, gcc-c++, glibc, glibc-devel, ksh, libaio, libaio-devel, libgcc, libstdc++, libstdc++-devel, make, or sysstat installed on your system. Make sure that the correct versions are installed. For the required versions, see Knowledge Article 169706.1."
                      [marcelo]: I have reinstalled the rmps but still get the same problem.

                      [root@student03 Packages_x86_32]# rpm -Uvh binutils-2*
                      Preparing... ########################################### [100%]
                      package binutils-2.20.51.0.2-5.34.el6.i686 is already installed

                      [root@student03 Packages_x86_32]# rpm -Uvh compat-libcap1*
                      Preparing... ########################################### [100%]
                      package compat-libcap1-1.10-1.i686 is already installed

                      [root@student03 Packages_x86_32]# rpm -Uvh compat-libstdc++*
                      Preparing... ########################################### [100%]
                      package compat-libstdc++-33-3.2.3-69.el6.i686 is already installed

                      [root@student03 Packages_x86_32]# rpm -Uvh gcc-4*[root@student03 Packages_x86_32]# rpm -Uvh glibc-2*
                      Preparing... ########################################### [100%]
                      package glibc-2.12-1.80.el6.i686 is already installed

                      Preparing... ########################################### [100%]
                      package gcc-4.4.6-4.el6.i686 is already installed

                      [root@student03 Packages_x86_32]# rpm -Uvh gcc-c++-4*
                      Preparing... ########################################### [100%]
                      package gcc-c++-4.4.6-4.el6.i686 is already installed

                      [root@student03 Packages_x86_32]# rpm -Uvh glibc-2*
                      Preparing... ########################################### [100%]
                      package glibc-2.12-1.80.el6.i686 is already installed

                      [root@student03 Packages_x86_32]# rpm -Uvh glibc-devel*
                      Preparing... ########################################### [100%]
                      package glibc-devel-2.12-1.80.el6.i686 is already installed

                      [root@student03 Packages_x86_32]# rpm -Uvh ksh*
                      Preparing... ########################################### [100%]
                      package ksh-20100621-16.el6.i686 is already installed

                      [root@student03 Packages_x86_32]# rpm -Uvh libaio*
                      Preparing... ########################################### [100%]
                      package libaio-0.3.107-10.el6.i686 is already installed
                      package libaio-devel-0.3.107-10.el6.i686 is already installed

                      [root@student03 Packages_x86_32]# rpm -Uvh libaio-devel*
                      Preparing... ########################################### [100%]
                      package libaio-devel-0.3.107-10.el6.i686 is already installed

                      [root@student03 Packages_x86_32]# rpm -Uvh libgcc*
                      Preparing... ########################################### [100%]
                      package libgcc-4.4.6-4.el6.i686 is already installed

                      [root@student03 Packages_x86_32]# rpm -Uvh libstdc++*
                      Preparing... ########################################### [100%]
                      package libstdc++-4.4.6-4.el6.i686 is already installed
                      package libstdc++-devel-4.4.6-4.el6.i686 is already installed

                      [root@student03 Packages_x86_32]# rpm -Uvh libstdc++-devel*
                      Preparing... ########################################### [100%]
                      package libstdc++-devel-4.4.6-4.el6.i686 is already installed

                      [root@student03 Packages_x86_32]# rpm -Uvh make*
                      Preparing... ########################################### [100%]
                      package make-1:3.81-20.el6.i686 is already installed

                      [root@student03 Packages_x86_32]# rpm -Uvh sysstat*
                      Preparing... ########################################### [100%]
                      package sysstat-9.0.4-20.el6.i686 is already installed

                      Thanks,

                      Marcelo
                      • 8. Re: Oracle Installer:[INS-13001] Environment does not meet minimum requirements
                        Marcelo Marques - ESRI
                        Hi,

                        I executed the installer as "./runInstaller -ignoreSysprereqs -ignorePrereq" and the installer did not return any warnings or error messages as expected.

                        I asked Oracle Support to try to reproduce the issue to determine if "[INS-13001] Environment does not meet minimum requirements." warning is a bug with the installer on OEL6.3 32-bit.

                        Thanks,

                        Marcelo
                        • 9. Re: Oracle Installer:[INS-13001] Environment does not meet minimum requirements
                          Marcelo Marques - ESRI
                          Hi,

                          I discussed with Oracle support and they didn't want to confirm it's a bug.

                          Hey, it's a bug!!!! It's clear the Oracle database 11.2.0.3 installer needs to be updated for OEL 6.3 version.

                          I closed the SR and accepted the workaroud suggested to turn off the system prerequisites checks.

                          "./runInstaller -ignoreSysprereqs -ignorePrereq"

                          I have installed the database software and created new databases just fine! Everything seems to be running fine!

                          Thanks,

                          Marcelo Marques
                          Esri, Technical Manager, OCP