This discussion is archived
3 Replies Latest reply: Jan 2, 2013 8:05 AM by apollon27 RSS

Many questions from a dummy in Forms Web

apollon27 Newbie
Currently Being Moderated
Hello, I have recently installed in my home Pc (Windows 7 Home Premium),
Database 11g, and Forms (64-bit) 11.1.2.00 just for training,
because I have only experience with 6i (Client-Server ) and wanted to see the new environment.

I have from my previous job (now unemployed) a small application (30 fmb) in 6i and want to make it run in the Web.
I have looked a little the pdf "Upgrading Oracle Forms 6i to Oracle Forms 11g (E24478-01)".

My fmxs and plls are in the folder C:\Retail_app\bin.
Also in this folder I have copied EnableDisableItem.pll and rp2rro.pll
The Sources (fmb, rdf ) are in the folder C:\Retail_app\Scr.

When I open the web, it appears me FRM-40039 Cannot attach library retail.pll while opening form shop.fmx

I search forum for this FRM and looked at FRM-40039 error post 32 bit to 64 bit migration. Please help.

Here, an oracle professional says that we must generate all plls into plx.

But when I try to do this, it says me FRM-91507 Internal error: Unable to generate library.

Also the expert says that it is important that you ensure that the file locations are included in FORMS_PATH (default.env).

My FORMS_PATH has "C:\Retail_App\Bin;C:\Oracle\Middleware\FRMHome\forms;C:\Oracle\Middleware\FrmInst\FormsComponent\forms"

I don't understand what default.env means. I am new to Forms Web environment.


Also another question, because I am Greek, the form builder environment is a half English a half Greek.
It does not say, "Attached Libraries" or "Program Units" or in the Menu it says "Parathiro" instead of "Window" . I want all to be in English.
Of course the language of my application is Greek, but I want Form Builder to be English.
My NLS_LANG is
GREEK_GREECE.EL8MSWIN1253

Is it wrong?

Also I would like to say supplementary,
that when I open shop.fmb in FormBuilder and go to the library retail.pll, then go to properties of the library, in the functional PL/SQL library location it says
Retail.pll.
it does not say C:\Retail_App\bin.

I tried this.

delete the library from shop.fmb, then attach it again, when asked "Remove path?" I answered No, but when I tried to start the application it says

FRM-10221, Cannot read file "C:\Oracle\Middleware\FrmIns
FRM-41810, Error creating menu

Pre-Form Trigger raised unhandled exception "ORA-06508"


I put messages in the PRE-FORM trigger of shop.fmb,
the trigger starts..

:system.message_level := '20';
message('1');
Create_Block_Rg; -- this is a prgram unit of the library Retail.pll
message('2');
:system.message_level := '0';


When I started again the application it appeared me message 1 and the failed, which means that it could not again read the pll.


Thank you all, and I wish you a happy new year (with joy and work).

Edited by: apollon27 on Dec 31, 2012 3:47 PM
  • 1. Re: Many questions from a dummy in Forms Web
    apollon27 Newbie
    Currently Being Moderated
    ...

    Edited by: apollon27 on Dec 31, 2012 3:46 PM
  • 2. Re: Many questions from a dummy in Forms Web
    Michael Ferrante (Oracle) Guru Moderator
    Currently Being Moderated
    In short, moving from one version to another is generally easy. In many cases, all that is necessary is that your generate new "X" files. In other words, you need to use the Forms 11 compiler or Builder to generate new FMX, MMX, and PLX files. Also, you cannot expect to use a pll at runtime. The pll files must be generated into plx files. The resulting new files should be located in a path which is included in FORMS_PATH. For runtime (browser), FORMS_PATH is set in default.env. For design-time (while working within the Builder), FORMS_PATH is set in the Registry in the same area that contains the other Forms entries. Keep in mind that when I say "design-time" this does not refer to launching a form in a browser from the Builder. Any time a form is running in a browser, all of its config comes from default.env.

    Also, in most cases, I would not recommend that when you attach a library that you choose not to remove the path. In other words, do not include the path when prompted. This is because if the path is retained, the form will not work correctly if the application is moved. Instead, choose to remove the path when attaching then ensure that the FORMS_PATH include the location of your libraries.

    So, to your exact comments:

    1. FRM-91507 Internal error: Unable to generate library. This is usually the result of FORMS_PATH not being set correctly or not including the path where references files are located. There have also been reports of this error resulting from setting NLS_LANG to certain languages. This issue was reported in Oracle bug 4131359. This bug has not yet been corrected. To determine if this is the problem, close the Builder and try setting NLS_LANG to something like the following:
    <blockquote>AMERICAN_AMERICA.UTF8</blockquote>
    This can either be set in the registry or as a Windows environment variable. After setting this value, restart the Builder or compiler and retest.

    2. You said, " +I don't understand what default.env+ ". You should become familiar with this file as you will revisit it often. This is the configuration file which contains the environment settings used by the Forms runtime (frmweb.exe). In version 11, this file can be found here:
    <blockquote>C:\Oracle\Middleware\user_projects\domains\ClassicDomain\config\fmwconfig\servers\WLS_FORMS\applications\formsapp_11.1.2\config</blockquote>
    In most cases, Oracle recommends that all configuration changes be made from within Enterprise Manager or WLS Console. The only exceptions would be if either of these tools do not manage a particular config file or if you are using the "Development" installation type. Installation types are explained here:

    http://docs.oracle.com/cd/E24269_01/doc.11120/e23960/install_screens.htm#BABCHIAF
  • 3. Re: Many questions from a dummy in Forms Web
    apollon27 Newbie
    Currently Being Moderated
    Thank you very much.
    The problem with the library (unable to generate plx) was NLS_LANG parameter. Also, I opened default.env with Notepad++ and changed FORMS_PATH.

    I wish you happy new year, health and creativity.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points