4 Replies Latest reply: Jun 25, 2013 5:40 AM by 967741 RSS


    Rohan Dekate
      Hi guys,
      I am trying to run wine application ,I created the application using deploy.bat in my C:\Endeca\apps\EndecaApplication\ATGproduction--- this is my application name
      i run following Batch file in this order initialize_services.bat----> load_test_baseline_data.bat-->baseline_update.bat.
      but when i access the localhost:8006 in admin console iam able to see data populated in dimension order
      but when iam accessing http://localhost:8006/endeca_jspref/
      i receive this error
      com.endeca.navigation.ENEException: Navigation Engine not able to process request 'http://localhost:15000/graph?node=0&offset=0&nbins=10&irversion=614'.
      I check the dgraph1.log file it says
      *ERROR     01/01/13 07:10:58.687 UTC (1357024258687)     DGRAPH     {dgraph}     Requested output IR version '614' is supported by this release of the software but not enabled. Use the --back_compat flag to enable the older IR version.*
      Iam using Mdex engine 6.2.2 and Platform services 6.1.3
      Can anybody give some hint about that why iam getting this error? what is --back_compat flag ? where to set it?
      Thanks in Advance
      Rohan Dekate
        • 1. Re: com.endeca.navigation.ENEException
          Pravin Chikhale
          Hi Rohan,

          This is dgraph flag you have to set in AppConfig.xml if the API version mismatches the MDEX (dgraph) running.

          Along with this flag u need to provide the API version backward support you needed.

          for example, 613 if you want backward compatibility support for 6.1.3 API version.


          • 2. Re: com.endeca.navigation.ENEException
            Rohan Dekate
            Hi Pravin,
            Thanks for responding .
            Can you tell where in AppConfig.xml file do I need to set this flag . And where I need to provide the API version backward support. If you dont mind ,Can you give a small code snapshot which would be very useful to me.
            Thanks in advance
            • 3. Re: com.endeca.navigation.ENEException
              you will have to add the --back_compat flag to the <dgraph-defaults> components <arg> section..

              some thing like

              or you can add the same through workbench admin console also...

              But if there is no specific reason, you should upgrade your client API's to get the full benefit of version 6.2.2

              Edited by: user7615588 on Jan 2, 2013 6:31 AM
              • 4. Re: com.endeca.navigation.ENEException




                Copy the following jar files:







                And paste it in the following location:





                hope this is helpful:D