8 Replies Latest reply: Jan 14, 2013 7:22 AM by hyperionEPM RSS

    Planning service keeps on stopping 11.1.2.2

    hyperionEPM
      Hello,

      I have installed EPM on a distributed architecture wherein Planning is on Server2 and Foundation is on Server1
      The issue is I am able to start the Planning service using the batch file that I have created to start it in the sequence.
      I was accessing Forms in the planning application and all of a sudden an error popped up - Error 503 Temporary Unavailable
      I went to the planning server and found that my planning service had stopped. I started the service again which started successfully,
      but when I check it in the Weblogic Admin Server console, it shows me in the Shutdown state. When I try to start it from there; it is not able to start the service.
      However if I stop the Planning service on the Planning server and start it using Admin Console, it starts and everything works fine.

      Now my issue is - I am not able to understand why does the planning service keep on stopping all of sudden. What should I do to resolve the issue.

      I tried redeploying it to the Application server again but that did not help.

      Thanks.
      HyperionEPM
        • 1. Re: Planning service keeps on stopping 11.1.2.2
          JohnGoodwin
          Is anything being generated in any of the logs when the crash happens?

          Cheers

          John
          http://john-goodwin.blogspot.com/
          • 2. Re: Planning service keeps on stopping 11.1.2.2
            hyperionEPM
            Hello John,

            I was going through the Readme for Hyperion Planning 11.1.2.2 and found across this

            9284400 -- Using the ampersand character (&) in form names can cause issues.

            And it seems like the Planning starts giving issues when I try to open a form which has an *&* in it

            Do you think the issue with Planning service getting stopped and then shows in shutdown state in Admin server console due to this? Any specific log that I should be referring to?

            Thanks.
            HyperionEPM
            • 3. Re: Planning service keeps on stopping 11.1.2.2
              JohnGoodwin
              Can you rename or create a copy of the form without the ampersand and see if it opens.

              Cheers

              John
              http://john-goodwin.blogspot.com/
              • 4. Re: Planning service keeps on stopping 11.1.2.2
                hyperionEPM
                I tried that, it still stops the planning service, and post which I start getting issues with Planning as it goes into Stopped state.

                I also have other forms which have & sign in it and which open just fine without any issues. Seems like there is some issues with the Form.

                Thanks,
                HyperionEPM
                • 5. Re: Planning service keeps on stopping 11.1.2.2
                  JohnGoodwin
                  If it is on windows you could check the planning logs in the diagnostics\logs\services folder or the web logic managed server logs.

                  Cheers

                  John
                  http://john-goodwin.blogspot.com/
                  • 6. Re: Planning service keeps on stopping 11.1.2.2
                    hyperionEPM
                    Nothing in the log specific to the forms... Here is the entry in the log which points to why the Planning service is not able to start


                    weblogic.management.ManagementException: Unable to obtain lock on D:\Oracle\Middleware\user_projects\domains\EPMSystem\servers\Planning0\tmp\Planning0.lok. Server may already be running
                         at weblogic.management.internal.ServerLocks.getServerLock(ServerLocks.java:206)
                         at weblogic.management.internal.ServerLocks.getServerLock(ServerLocks.java:67)
                         at weblogic.management.internal.DomainDirectoryService.start(DomainDirectoryService.java:74)
                         at weblogic.t3.srvr.ServerServicesManager.startService(ServerServicesManager.java:461)
                         at weblogic.t3.srvr.ServerServicesManager.startInStandbyState(ServerServicesManager.java:166)
                         at weblogic.t3.srvr.T3Srvr.initializeStandby(T3Srvr.java:882)
                         at weblogic.t3.srvr.T3Srvr.startup(T3Srvr.java:572)
                         at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:469)
                         at weblogic.Server.main(Server.java:71)

                    Thanks,
                    HyperionEPM
                    • 7. Re: Planning service keeps on stopping 11.1.2.2
                      hyperionEPM
                      Hello John,

                      There is nothing specific in the Sysout and Syserr logs for Planning. But I checked the ohs_component log and I found the following entries in it -
                      [2013-01-08T02:24:08.4142-06:00] [OHS] [ERROR:32] [OHS-9999] 
                      [mod_weblogic.c] [host_id: srv2751] 
                      [host_addr: 10.3.3.146] [pid: 6948] [tid: 4392] [user: SYSTEM] [VirtualHost: fusion.hyperion.com:19000]  
                      ap_proxy: trying POST /HyperionPlanning/modules/com/hyperion/planning/Adf.jsp at backend 
                      host '10.3.3.147/8300; got exception 'CONNECTION_REFUSED [os error=0, line 1582 of ../common/URL.cpp]: 
                      apr_socket_connect call failed with error=730061, host=10.3.3.147, port=8300 ', 
                      referer: http://fusion.hyperion.com:19000/workspace/index.jsp?framed=true
                      My Planning service starts, I can also work on it without any issues, but if that remains idle it goes into Shutdown state (as seen in the Admin Server console). The Planning service however remains in started state on the Planning server. But when I try to access a planning application, I cannot access it until the state for Planning0 changes from Shutdown state to Running state in Admin Server.

                      Any help will be highly appreciated.

                      Thanks,
                      HyperionEPM
                      • 8. Re: Planning service keeps on stopping 11.1.2.2
                        hyperionEPM
                        Installed Node Manager Service on the Planning server, kept it to automatic mode..