13 Replies Latest reply on Jan 29, 2013 9:16 AM by User592717-OC

    Document Manager Taskflow

      Hi There,

      I have created a sample webcenter portal application and I have consumed a Document manager taskflow in my TestPage.jspx.

      I have configure the Document manger taskflow with the folder path, username, password and context path. Then I ran the application. it's working perfectly fine and I am able to view all document under that folder in my TestPage.jspx. But when I try to view the metadata of any document in the given folder through Document manager Taskflow, its throwing exception.

      Target Unreachable, 'values' returned null
      ADF_FACES-60096:Server Exception during PPR, #1

      When I check the log I am gettting following exception.

      <UIXRegion> <_warn> Error processing viewId: /doclib-document-information/info URI: /oracle/webcenter/doclib/view/jsf/taskflows/docViewer/docInfo.jsff actual-URI: /oracle/webcenter/doclib/view/jsf/taskflows/docViewer/docInfo.jsff.
      javax.el.PropertyNotFoundException: Target Unreachable, 'values' returned null
      at com.sun.el.parser.AstValue.getTarget(Unknown Source)
      at com.sun.el.parser.AstValue.getType(Unknown Source)

      Please provide me any resolution to this issue, will be highly appreciated.

        • 1. Re: Document Manager Taskflow
          Try to inspect the <af:region> object. It has a parameter called 'value', which defines what documents should be displayed. Mine (displays all the available folders) has the value '#{bindings.doclibdocumentlibrary1.regionModel}'

          See also: http://docs.oracle.com/cd/E21764_01/webcenter.1111/e10273/createconnect.htm#BGBFJFFB
          (though, it's a bit strange that you could view documents if something was missing)
          • 2. Re: Document Manager Taskflow
            Hi Jiri,

            Thanks for your information. I have verified <af:region> object and it has a parameter called 'value', please find below the code.

            <af:region value="#{bindings.doclibdocumentlibrary1.regionModel}"

            It's able to view all folders and content but when I try to view the properties (i.e. metadate) then it's throwing exception.

            Please advice.

            • 3. Re: Document Manager Taskflow
              I am not able to replicate your issue. Therefore, I can only guess.

              The first question to ask is if you have the same environment - do you use WebCenter Content as your repository?

              The next question is: what exactly do you do to view properties (metadata)?

              I've tried two ways:
              - in Document Manager right click on a checked-in file and choose 'Details...' and then open the 'Info' tab
              - double-click a checked-in file and then open the 'Info' tab

              You could also verify what's happening at the Content side - see this link how to turn on system-wide tracing http://docs.oracle.com/cd/E23943_01/doc.1111/e10792/c03_processes.htm#CSMSP536 (you will need requestaudit).

              Opening a page with the Document Manager executes a service called COLLECTION_DISPLAY
              The two mentioned ways execute other services such as GET_DOC_METADATA_INFO, DOC_INFO_BY_NAME, or DOC_INFO.

              You should verify
              a) whether the appropriate service was called
              b) whether it has got any error while executed

              If the service is not called, or is called with no errors (this means: something is wrong with passing back the results), then the problem might be at the WebCenter Portal side - this can be quite tedious to find, but you will have to revisit the configuration of the Documents Service http://docs.oracle.com/cd/E21764_01/webcenter.1111/e12405/wcadm_documents.htm#CIHIJFCC I'd start with an obvious step - checking the file docInfo.jsff mentioned in the error message (but I'd not know what exactly the file should look like). If the problem is at WebCenter Content side, you might get some hint from the tracking console.
              1 person found this helpful
              • 4. Re: Document Manager Taskflow
                Hi Jiri,

                I am using same environment and I am having Webcenter content (UCM) as my repository.

                I want to edit metadata through document manager taskflow.

                I have followed one of the two option you mentioned in your reply.

                in Document Manager right click on a checked-in file and choose 'Details...' and then open the 'Info' tab

                Than same issue persists, here is the requestaudit.
                requestaudit/6     01.07 08:01:33.848     IdcServer-32920     PING_SERVER [dUser=NSTIPAdmin][StatusMessage=You are logged in as 'NSTIPAdmin'.][IsJava=1] 0.043912000954151154(secs)
                requestaudit/6     01.07 08:01:34.412     IdcServer-32921     GET_ENVIRONMENT [dUser=NSTIPAdmin][IsJava=1] 0.01547900028526783(secs)
                requestaudit/6     01.07 08:01:35.261     IdcServer-32922     CONFIG_INFO [dUser=NSTIPAdmin][IsJava=1] 0.0468440018594265(secs)
                requestaudit/6     01.07 08:01:38.130     IdcServer-32923     GET_DOCPROFILES [dUser=NSTIPAdmin][IsJava=1] 0.025829000398516655(secs)
                requestaudit/6     01.07 08:01:38.761     IdcServer-32925     GET_ADVANCED_SEARCH_OPTIONS [dUser=NSTIPAdmin][IsJava=1] 0.0624070018529892(secs)
                requestaudit/6     01.07 08:01:39.371     IdcServer-32924     COLLECTION_INFO [dDocTitle=KACST News][dUser=weblogic][IsJava=1] 1.1112899780273438(secs)
                requestaudit/6     01.07 08:01:40.123     IdcServer-32926     COLLECTION_GET_ADMIN_MARKED_CONFIG [dUser=NSTIPAdmin][IsJava=1] 0.04034800082445145(secs)
                requestaudit/6     01.07 08:01:40.899     IdcServer-32927     GET_USERS [dUser=NSTIPAdmin][IsJava=1] 0.010420000180602074(secs)
                requestaudit/6     01.07 08:01:41.435     IdcServer-32928     GET_USER_PERMISSIONS [dUser=NSTIPAdmin][IsJava=1] 0.017069000750780106(secs)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     Invalid NULL value retrieved in ResultSet exception stack
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     java.lang.Throwable: Invalid NULL value retrieved in ResultSet
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at intradoc.data.DataResultSet.getStringValue(DataResultSet.java:2139)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at intradoc.serialize.DataBinderSerializer.packageResultSet(DataBinderSerializer.java:336)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at intradoc.serialize.DataBinderSerializer.sendEx(DataBinderSerializer.java:169)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at intradoc.serialize.DataBinderSerializer.sendBytes(DataBinderSerializer.java:238)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at intradoc.data.DataSerializeUtils.sendBytes(DataSerializeUtils.java:75)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at intradoc.data.DataBinder.sendBytes(DataBinder.java:2034)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at intradoc.server.Service.buildDataBinderResponse(Service.java:1752)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at intradoc.server.Service.sendDataBinder(Service.java:1685)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at intradoc.server.Service.doResponse(Service.java:2072)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at intradoc.server.SearchService.doResponse(SearchService.java:2102)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at intradoc.server.ServiceRequestImplementor.doRequest(ServiceRequestImplementor.java:802)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at intradoc.server.Service.doRequest(Service.java:1890)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at intradoc.server.ServiceManager.processCommand(ServiceManager.java:435)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at intradoc.server.IdcServerThread.processRequest(IdcServerThread.java:265)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at intradoc.server.IdcServerThread.run(IdcServerThread.java:160)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:528)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
                (internal)/7     01.07 08:01:41.535     IdcServer-32929     at weblogic.work.ExecuteThread.run(ExecuteThread.java:178)
                requestaudit/6     01.07 08:01:41.539     IdcServer-32929     GET_SEARCH_RESULTS [dUser=weblogic][QueryText=%28+xCollectionID+%3d+%60381040604418011093%60%3cand%3e+xIsUsed+%3cmatches%3e+%60Yes%60+%29][xCollectionID=381040604418011093][IsJava=1] 0.0994739979505539(secs)
                I am not able to figure it out what would be the issue???

                • 5. Re: Document Manager Taskflow
                  This certainly provides some information.

                  Kindly observe that it fails on a service GET_USER_PERMISSIONS, not DOC_INFO.

                  Just for verification I'd recommend you to login to UCM with the same user - I guess you will get similar kinds of errors too.

                  Either way, I found an article which discusses the matter: http://studentsatoracle.blogspot.co.uk/2011/02/setting-permissions-between-oracle-ucm.html
                  • 6. Re: Document Manager Taskflow
                    Hi Jiri,

                    Thanks for your inputs, it was helpful.
                    I have gone through the url which was provide by you. And more over I am able to log into UCM with user NSTIPAdmin, able to edit content and metadata.

                    I don't why I am not able to do that same with Document Manager taskflow??

                    Any suggestions will be highly appreciated.

                    • 7. Re: Document Manager Taskflow
                      Hmmm, that looks interesting...

                      In fact, you should be able run the Document Manager even for an anonymous user.

                      Unfortunately, GET_USER_PERMISSIONS is not a documented service, but I found a very good article describing it: https://blogs.oracle.com/kyle/entry/getting_a_list_of_security

                      Do you know how to execute services directly in UCM? (... just replace ending in the URL after idcplg?IdcService= with idcplg?IdcService=GET_USER_PERMISSIONS&IsJava=1)
                      Can you find differences what's returned when you log in as NSTIPAdmin and as weblogic or anonymous (copy the URL, close the broswer, open the browser, and copy the URL back without login)?

                      Also, can you try what happens with the Document Manager if you run it as an anonymous user, or weblogic?
                      • 8. Re: Document Manager Taskflow
                        Hi Jiri,

                        Thanks for your valuable suggestion. I have tried to run the below steps with NSTIPAdmin and weblogic both are giving providing almost same result. I even tried to run the AdminModule with weblogic user even then also throwing the same exception.

                        I really don't understand it's working fine while retriving the results (like file and folders) but when I try to view the properties ( metadatas ) of any specify content then it's throwing exception.

                        It's quite strange, why this is behaving like this.
                        • 9. Re: Document Manager Taskflow
                          Let me recap that:

                          a) UCM (Content) side
                          - login to UCM works for both NSTIPAdmin and weblogic, you can view and edit metadata as well as execute the GET_USER_PERMISSIONS service; no exception thrown

                          b) WebCenter Portal side
                          - the same exception thrown for NSTIPAdmin and weblogic

                          Is that right? If so, I'm almost at my wits' end as Sherlock Holmes used to say. It could seem that something is wrong between Content and Portal, but if you can see content items (btw. if you double-click a content item, can you see what's in the file?) you should be able to see also its metadata

                          One last idea is this: maybe the error does not refer to GET_USER_PERMISSIONS, but to GET_SEARCH_RESULTS. Can you try to execute also this service with the given parameters? I think I have seen issues when NULL is returned by this service - search WebCenter Content forum for GET_SEARCH_RESULTS AND NULL, if that theory comes true.
                          • 10. Re: Document Manager Taskflow
                            Hi Jiri,

                            Yes you are correct.

                            a) UCM (Content) side
                            - login to UCM works for both NSTIPAdmin and weblogic, you can view and edit metadata as well as execute the GET_USER_PERMISSIONS service; no exception thrown

                            b) WebCenter Portal side
                            - the same exception thrown for NSTIPAdmin and weblogic

                            It's not only the case with Document Manager Taskflow but even when I go to WebCenter Portal Administration by loging as NSTIPAdmin or weblogic in either case it's throwing exception while viewing properties (metadata).

                            As I am using UCM and WebCenter

                            I doubt it's related to our environment, is there any specific path I need to add?

                            • 11. Re: Document Manager Taskflow
                              I'm afraid I have exhausted my ideas. There seems to be something between WCP and WCC. I had thought that your issue might be security-related, but if you can observe it also for 'weblogic' user, who usually has all the permissions, this hypothesis does not seem to be correct.

                              You may have to contact the official support via Metalink so that your issue is investigated. The only other option I see to install WebCenter Portal and configure the connection to the Content Repository from the scratch. Since we don't know the cause this exercise might be in vain, but chances are that your issue disappears.
                              • 12. Re: Document Manager Taskflow
                                Hi Jiri,

                                After doing lot of analysis I figured it out that there seems to be issue with Custom metadata in our UCM default profile. Is there any way to configure Document Manager Taskflow with Custom profile ?

                                Awaiting for your kind reply.

                                Thanks in advance!!!
                                • 13. Re: Document Manager Taskflow
                                  Thanks I am able to resolve this issue.