This discussion is archived
4 Replies Latest reply: Jan 7, 2013 3:06 AM by RichDBA RSS

Question regarding System Requirements for 2.0

RichDBA Newbie
Currently Being Moderated
The below link to the System requirements for the 2.0 listener state that Microsoft Internet Explorer 8 or later is required. Why is this?

http://docs.oracle.com/cd/E37099_01/doc/doc.20/e25066/install.htm#CHDDEDFJ

Surely if configuration is done through SQL Developer or the Command Line, there isn't a specific browser requirement? Surely the listener is a server side component, is anyone able to enlighten me?

Regards
Rich

Edited by: RichDBA on Jan 2, 2013 3:40 PM
  • 1. Re: Question regarding System Requirements for 2.0
    AndyPol Expert
    Currently Being Moderated
    In my opinion are 2 reason:
    1. IE 7 and lower have many many bugs.
    2. Apex Listener 2.0 has own Error pages, probably this pages can't work or not correct work with IE7 and lower.

    Regards
  • 2. Re: Question regarding System Requirements for 2.0
    RichDBA Newbie
    Currently Being Moderated
    When you say its own error pages, do you mean pages presented for HTML status codes, such as 404 and 501 etc? If so, then I guess that could be the case, but I can't believe that those pages would be so advanced that they don't work in browsers earlier than IE8.

    We currently use IE6 in our enterprise environment (soon to be moving to IE8) so I was really hoping to find out if I could get by with IE6 for the short period before we change over.

    Is anyone out there using the 2.0 listener with browsers older then IE8, are you experiencing any issues?

    Regards
    Rich
  • 3. Re: Question regarding System Requirements for 2.0
    Udo Guru
    Currently Being Moderated
    Hi Rich,

    I didn't test AL 2.0 with IE 6, but I don't see a reason why this shouldn't work. I think this requirement has been forwarded from APEX Listener 1 (and 1.1, respectively), which has a web based admin GUI that used CSS features IE 6 didn't implement. Possibly the current error pages may not appear well formatted if you view them in IE 6, but I don't think this would be a no-go for production.
    You shoul keep in mind, that current APEX releases require at least IE 7 to work properly, at least with themes provided by these releases. But if you don't experience any issues with your APEX release, using APEX Listener 2 instead of your current web server for APEX won't make any difference.

    -Udo
  • 4. Re: Question regarding System Requirements for 2.0
    RichDBA Newbie
    Currently Being Moderated
    Thanks Udo,

    I had assumed that it was possibly a hangover of the previous version that was configured via the browser. I think based on this information I'll push ahead with my implementation.

    Regards
    Rich

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points