1 2 Previous Next 22 Replies Latest reply: Jan 3, 2013 11:21 PM by Harsh_v RSS

    after sqlplus command get nothing output

    Harsh_v
      Hi everyone,


      I have successfully installed oracle (10gR2) software on Linux server (Redhat 5.5). and when i will log in throw

      sqlplus /nolog

      then i got nothing output, even i have set ORACLE_HOME, ORACLE_BASE in bash profile. i have log below
      [root@VCC-MCA-5 ~]# sqlplus
      [root@VCC-MCA-5 ~]#
      [root@VCC-MCA-5 ~]# which sqlplus
      
      /home/oracle/app/oracle/product/10.2.0/bin/sqlplus
      please suggest where i am wrong.

      Regards
        • 1. Re: after sqlplus command get nothing output
          Fran
          wrong user
          root
          • 2. Re: after sqlplus command get nothing output
            sb92075
            Harshit DBA india wrote:
            Hi everyone,


            I have successfully installed oracle (10gR2) software on Linux server (Redhat 5.5). and when i will log in throw

            sqlplus /nolog

            then i got nothing output, even i have set ORACLE_HOME, ORACLE_BASE in bash profile. i have log below
            [root@VCC-MCA-5 ~]# sqlplus
            [root@VCC-MCA-5 ~]#
            [root@VCC-MCA-5 ~]# which sqlplus
            
            /home/oracle/app/oracle/product/10.2.0/bin/sqlplus
            please suggest where i am wrong.

            Regards
            NEVER use OS root user to access anything involving oracle

            post results from OS commands below

            id
            env | sort
            strace sqlplus
            • 3. Re: after sqlplus command get nothing output
              Harsh_v
              actually same issue from oracle user too....
              [oracle@VCC-MCA-5 ~]$ sqlplus
              [oracle@VCC-MCA-5 ~]$
              
              
              [oracle@VCC-MCA-5 ~]$ which sqlplus
              ~/app/oracle/product/10.2.0/bin/sqlplus
              [oracle@VCC-MCA-5 ~]$ env | sort
              _=/bin/env
              CVS_RSH=ssh
              G_BROKEN_FILENAMES=1
              HISTSIZE=1000
              HOME=/home/oracle
              HOSTNAME=VCC-MCA-5
              INPUTRC=/etc/inputrc
              KDEDIR=/usr
              KDE_IS_PRELINKED=1
              KDE_NO_IPV6=1
              LANG=en_US.UTF-8
              LESSOPEN=|/usr/bin/lesspipe.sh %s
              LOGNAME=oracle
              LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
              MAIL=/var/spool/mail/oracle
              ORACLE_BASE=/home/oracle/app/oracle
              ORACLE_HOME=/home/oracle/app/oracle/product/10.2.0/
              ORACLE_SID=orcl
              ORACLE_TERM=term
              PATH=/usr/lib64/qt-3.3/bin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/home/oracle/bin:/home/oracle/app/oracle/product/10.2.0//bin:
              PWD=/home/oracle
              QTDIR=/usr/lib64/qt-3.3
              QTINC=/usr/lib64/qt-3.3/include
              QTLIB=/usr/lib64/qt-3.3/lib
              SHELL=/bin/bash
              SHLVL=1
              SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
              TERM=xterm
              USER=oracle
              [oracle@VCC-MCA-5 ~]$ strace sqlplus
              execve("/home/oracle/app/oracle/product/10.2.0//bin/sqlplus", ["sqlplus"], [/* 29 vars */]) = -1 ENOEXEC (Exec format error)
              dup(2)                                  = 3
              fcntl(3, F_GETFL)                       = 0x8002 (flags O_RDWR|O_LARGEFILE)
              fstat(3, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 1), ...}) = 0
              mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x2b17b8d45000
              lseek(3, 0, SEEK_CUR)                   = -1 ESPIPE (Illegal seek)
              write(3, "strace: exec: Exec format error\n", 32strace: exec: Exec format error
              ) = 32
              close(3)                                = 0
              munmap(0x2b17b8d45000, 4096)            = 0
              exit_group(1)                           = ?
              Edited by: Harshit DBA india on Jan 3, 2013 8:59 PM
              • 4. Re: after sqlplus command get nothing output
                sb92075
                ORACLE_HOME=/home/oracle/app/oracle/product/10.2.0/
                not a above, but as below
                ORACLE_HOME=/home/oracle/app/oracle/product/10.2.0
                trailing slash character removed!
                • 5. Re: after sqlplus command get nothing output
                  Harsh_v
                  same issue....
                  [oracle@VCC-MCA-5 ~]$ cat .bash_profile
                  # .bash_profile
                  
                  # Get the aliases and functions
                  if [ -f ~/.bashrc ]; then
                          . ~/.bashrc
                  fi
                  
                  # User specific environment and startup programs
                  
                  PATH=$PATH:$HOME/bin
                  
                  export PATH
                  
                  export ORACLE_BASE=/home/oracle/app/oracle
                  export ORACLE_HOME=/home/oracle/app/oracle/product/10.2.0
                  export ORACLE_SID=orcl
                  export ORACLE_TERM=term
                  export PATH=$PATH:$ORACLE_HOME/bin:
                  
                  [oracle@VCC-MCA-5 ~]$ . .bash_profile
                  [oracle@VCC-MCA-5 ~]$
                  [oracle@VCC-MCA-5 ~]$ sqlplus
                  [oracle@VCC-MCA-5 ~]$
                  • 6. Re: after sqlplus command get nothing output
                    sb92075
                    write(3, "strace: exec: Exec format error\n", 32strace: exec: Exec format error

                    OS & Oracle 32 or 64 bit?

                    When was last time sqlplus ran without error?
                    what changed since then?
                    • 7. Re: after sqlplus command get nothing output
                      Fran
                      it looks like forgot something here
                      execve("/home/oracle/app/oracle/product/10.2.0//bin/sqlplus", ["sqlplus"]
                      incomplete path
                      • 8. Re: after sqlplus command get nothing output
                        Harsh_v
                        OS is Redhat 5.5 (64 bit)
                        Oracle software is 32 bit setup...

                        this is the fresh server and Oracle is installed first time on there.


                        Reg....
                        • 9. Re: after sqlplus command get nothing output
                          Fran
                          OS is Redhat 5.5 (64 bit)
                          Oracle software is 32 bit setup...
                          Deinstall and install Oracle software 64bits
                          • 10. Re: after sqlplus command get nothing output
                            Harsh_v
                            But We can install Oracle 32 bit on 64 bit OS (linux)
                            • 11. Re: after sqlplus command get nothing output
                              Fran
                              Yes, you can....with errors
                              • 12. Re: after sqlplus command get nothing output
                                Harsh_v
                                what you mean we install 32 bit oracle on 64 bit Linux with error.


                                But i have already install this scenario on many server without error. why i got error on this server?
                                • 13. Re: after sqlplus command get nothing output
                                  Fran
                                  Installation and Configuration Requirements Quick Reference (8.0.5 to 11.2) [ID 169706.1]

                                  why you install 32 bits software in 64 bits OS if you have 64 bits software available?

                                  Edited by: Fran on 03-ene-2013 8:13
                                  • 14. Re: after sqlplus command get nothing output
                                    Harsh_v
                                    Dear Sir, this is client requirement. :)

                                    what could i do in this case...
                                    1 2 Previous Next