5 Replies Latest reply: Jan 3, 2013 2:46 PM by NewApexCoder RSS

    Process to populate an item/field?

    NewApexCoder
      So here's the scenario:

      I have a report with a list of organizations. I have a button that takes you to a form to add a new organization. When you navigate to the form, you fill in the fields and press create. Some of the fields included are organization name, org type, the address, state, etc. These are all items. I also have an item named Last_Edited_By_User on that form. Upon creating a new organization, the Last_edited_By_User should be populated with the authenticated user or APP_USER. However, I am having some problems in doing so. Under Page Processing, I have tried creating a separate process under the "process Row of ORGANIZATIONS" process to make this happen, but nothing happens or my program crashes. Any suggestions? Thanks in advance

      #ConfusedApexGuy
        • 1. Re: Process to populate an item/field?
          riedelme
          963510 wrote:
          So here's the scenario:

          I have a report with a list of organizations. I have a button that takes you to a form to add a new organization. When you navigate to the form, you fill in the fields and press create. Some of the fields included are organization name, org type, the address, state, etc. These are all items. I also have an item named Last_Edited_By_User on that form. Upon creating a new organization, the Last_edited_By_User should be populated with the authenticated user or APP_USER. However, I am having some problems in doing so. Under Page Processing, I have tried creating a separate process under the "process Row of ORGANIZATIONS" process to make this happen, but nothing happens or my program crashes. Any suggestions? Thanks in advance

          #ConfusedApexGuy
          Have you tried using :APP_USER as a default value for the item?
          • 2. Re: Process to populate an item/field?
            NewApexCoder
            Yes. So even when I go to my form to create a new organization, the Last_Edited_By_UserID is displayed with the :APP_USER value. It's when I click 'create' that this value is not being saved into the database. It's not being saved. When I go back to the report, I see the record that I just created with the correct values that I filled into the form, except for the Last_Edited_By_UserId. That field is still blank.

            #FrustratedApexGuy
            • 3. Re: Process to populate an item/field?
              Matthew Morris
              Have you tried using :APP_USER as a default value for the item?
              Assuming the "Default Value Type" is left to the default of "Static Text with Session State Substitutions", he would use &APP_USER. rather than :APP_USER
              • 4. Re: Process to populate an item/field?
                Matthew Morris
                If you are using a 'Display Only' page item, then you must explicitly set the page item to save session state under the 'Settings' region. Otherwise the value is treated as NULL during the SUBMIT.
                • 5. Re: Process to populate an item/field?
                  NewApexCoder
                  Oh I see, let me experiment with a few things and try this out to see if it works. Thanks for the suggestions.