2 Replies Latest reply: Jan 7, 2013 9:01 AM by boyd4715 RSS

    Eclipse Galileo performance problem

    Prateek G
      I have installed atg plugins in eclipse galileo but whenever I open any jsp/java/properties file it stops working or whene I clicks on any line the cursor got stuck for a while.
      mu eclipse.ini settings are as below-
      --launcher.XXMaxPermSize
      256M
      -showsplash
      org.eclipse.platform
      --launcher.XXMaxPermSize
      256m
      -vmargs
      -Dosgi.requiredJavaVersion=1.5
      -Xms40m
      -Xmx256m

      and JBOSS's run.bat setting is as below-
      set JAVA_OPTS=%JAVA_OPTS% -Xms128m -Xmx256m -XX:MaxPermSize=128m -XX:MaxNewSize=256m

      I have tried to increase the size of -Xms and -Xmx but problem is not solved, please help.

      i am using Windows 7 (32 bit), 2 GB RAM. Please help me regarding this
        • 1. Re: Eclipse Galileo performance problem
          951576
          Hi,

          Try increasing your system virtual memory and see.
          I was facing the same problem, by increasing system virtual memory issue is resolved.

          --Venkat                                                                                                                                                                                                                                                                                                                       
          • 2. Re: Eclipse Galileo performance problem
            boyd4715
            My first question to you is why are you using such an old version of Eclipse?

            Here is my setting for running Eclipse with ATG:

            -clean
            -startup
            plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar
            --launcher.library
            plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.2.R36x_v20101019_1345
            -product
            org.eclipse.epp.package.java.product
            --launcher.defaultAction
            openFile
            -showsplash
            org.eclipse.platform
            --launcher.XXMaxPermSize
            256m
            --launcher.defaultAction
            openFile
            -vmargs
            -Dosgi.requiredJavaVersion=1.5
            -XX:MaxPermSize=256m
            -Xms40m
            -Xmx384m

            I am running Eclipse Helios Service Release 2 (a little newer) on RedHat 5.1 (64 bit) with JDK 1.6.0_22-b04 (64 bit).