1 Reply Latest reply: Jan 7, 2013 11:40 AM by MrBrown RSS

    Java 7 support

    mvlonden
      Hi,

      According to the SGD 4.70 documentation Java 7 is not supported.
      But due to security issues people are forced to install Java 7, also Oracle published the following notification about end-of-life of Java 6

      http://www.oracle.com/technetwork/java/javase/documentation/autoupdate-1667051.html.

      We use SGD 4.60 with a third-party authentication method through RADIUS.
      When you use Java 7, you will get a second login window (Authentication Required) after logging in, because of the incompatibility of Java 7 (at least prior to update 10).
      Strangely enough, when hitting the cancel button in this second login window, the login process continues without any problems and you have access to the webtop.

      But after updating to version 7 update 10 this second login windows has disappeared.

      I've tested this on a Windows 7 64-bits machine with Java 7u10 32-bits and IE8.
      Also with Firefox 17.0.1.

      Can somebody confirm that Java 7 update 10 is now compatible with SGD 4.60 and above?

      Thanks,
      Michael
        • 1. Re: Java 7 support
          MrBrown
          SGD supports Java 7 on SGD 4.7 as per the documentation

          http://docs.oracle.com/cd/E26362_01/E26357/html/reqs-client.html#reqs-client-platforms


          Java Plug-in software versions 1.6 and 1.7 are supported as a plug-in for Java technology.

          Note
          For details of known issues when using Java Plug-in software version 1.7, see knowledge document ID 1487307.1 on My Oracle Support (MOS).

          SGD 4.6x does not officially support Java 7 but similar issues seen with SGD 4.7 might be seen with SGD 4.6x and the solutions/workarounds in knowledge document ID 1487307.1 might also be relevant on SGD 4.6x. If you have an issue on SGD 4.6x with Java 7, then you should test with SGD 4.7 and review knowledge document ID 1487307.1 to see if it resolves your issue.