1 2 Previous Next 19 Replies Latest reply on Jan 11, 2013 5:22 PM by Sh!va

    ESSBASE Error - 1030818

      Hi All,

      OS : Windows 7 and Hyperion

      I am facing some critical errors in Essbase, suddenly my essbase was down, i am trying to figure out the issues, but i couldn't it.....

      Unexpected Essbase Error:

      error: 103: Unexpected Essbase error 1030818
      Error: 1042006: Network error [10061]: Failed to connect to [citta3:1423]
      Error: 1030818: Login failed. Please check if server and port are correct. If you received timeout or handshake failure, please check if you tried to connect to secure port without secure keyword or clear port with secure keyword.

      Tried Solutions:

      *1) Checked the Essbase server is up or not using opmnctl cmd, the status was down, i am trying to start the essbase using opmnctl startproc ias-component=Essbase1, but the essbase is not starting and tried using the startEssbase.bat, but no luck...*

      Log of OPMNCTL:

      --> Process (index=1,uid=2109082185,pid=11088)
      failed to start a managed process after the maximum retry limit

      Checked the log(console~Essbase1~EssbaseAgent~AGENT~1.log) in above path:

      13/01/08 09:44:38 Start process

      13/01/08 09:44:42 Start process

      13/01/08 09:44:44 Start process

      13/01/08 10:40:23 Start process

      13/01/08 10:40:27 Start process

      13/01/08 10:40:29 Start process

      *2) Tried to check the solution for the above issue in Oracle Support - I got the below solution, but i dont have the existing working copy of opmn.xml file*

      Error 5:

      Process (index=1,uid=1201890034,pid=28160)
      failed to start managed process after the Maximum retry limit


      Errors 4, 5, 6 occur when validation for OPMN.xml File fails.
      Hence, compare the OPMN.xml file with the OPMN.xml file on the Working Environment, and restore it.

      3) I have reconfigured entire Essbase itself, configuration succeeded without any issues, but still i am facing the essbase issues.

      Issue 2:

      From the beginning itself, workspace is not working... i tried a lot to resolve, but no luck...

      Did anyone come across this issues, please guide me...

      Note: I am using VMware Hyperion copy in the same machine, after this issues, i disabled entire vmware and restarted and tried the above solutions, but no luck.... Installed Hyp in base machine...

        • 1. Re: ESSBASE Error - 1030818

          Are you able to start Essbase in foreground mode ?
          • 2. Re: ESSBASE Error - 1030818
            You can compare the opmn.xml from other environment. Just to check the maximum tag some thing.

            Once your opmn service is up than try to start essbase.


            • 3. Re: ESSBASE Error - 1030818
              Hi All,

              Thank you for your prompt replies.... I tried to start the Essbase foreground mode... but no luck... facing the same issues

              I dont have existing copy of old opmn.xml, because i am working in my laptop...

              • 4. Re: ESSBASE Error - 1030818
                Then in that case the issue is not OPMN.

                What error are you facing when starting Essbase in foreground ?
                • 5. Re: ESSBASE Error - 1030818
                  Are you saying essbase is running on Windows 7, if so it is not actually supported (yes it is possible to get it working)
                  Can you confirm OPMN is definitely starting by running from command line in <MIDDLEWARE_HOME>/user_projects/<instancename>/bin/

                  opmnctl start

                  from your first post it sounds like OPMN is actually starting but I just wanted to confirm.

                  if it is starting then what are the essbase related logs displaying when you try to start essbase from OPMN e.g. essbase.log and SharedServices_Security_Client.log
                  There is a possibility is may even be a corrupt essbase.sec and restoring a backup could help though check the above logs first.


                  • 6. Re: ESSBASE Error - 1030818
                    Hi John,

                    Thank you for your prompt reply....

                    I have already checked the log files essbase.log and SharedServices_Security_Client.log... Both files are not updated any logs today, its showing the previous logs only....

                    I can able to see the Essbase.sec from below location C:\Oracle\Middleware\user_projects\epmsystem1\EssbaseServer\essbaseserver1\essbase.sec


                    Edited by: dwhpc on Jan 8, 2013 3:26 PM
                    • 7. Re: ESSBASE Error - 1030818
                      If you have a backup of the .sec from when essbase worked you could try replacing it.


                      • 8. Re: ESSBASE Error - 1030818
                        Even if you can see essbase.sec, John meant that it may be corrupt. Make a copy of the current essbase.sec, and rename essbase.bak that should be in the same folder to essbase.sec and try to start essbase again. If it still doesn't work you can at least rule out a corrupt sec file.
                        • 9. Re: ESSBASE Error - 1030818
                          don't always rely on essbase.bak though as sometimes that can be corrupt, though this is all based on the sec file being corrupt in the first place.


                          • 10. Re: ESSBASE Error - 1030818
                            Hi John,

                            I dont have any backup of essbase.sec file, i tried to replace the essbase.sec from the epm backup (C:\Oracle\Middleware\user_projects\epmsystem1\EssbaseServer\essbaseserver1\bin\backups\essbase.sec.backup) folder.... but no luck... facing the same issues... seems the backup files also corrupted...

                            Is there any workaround to solve this issue?

                            • 11. Re: ESSBASE Error - 1030818
                              Are your able to start OPMN ?

                              opmnctl.bat status

                              If yes, than try to create a copy of startMxl.bat with any name and in that copy replace essmsh to Essbase. try to execute it. you will get more details of error.(you will get startMaxl.bat under %ARBORPATH%\bin.

                              If not,

                              Can you paste your opmn.xml here so that we can refer from over environment. i am sure there is one filed we need to change for this maximun try error,but can't recall that.


                              1 person found this helpful
                              • 12. Re: ESSBASE Error - 1030818
                                Hi Shiva,

                                Thank you for your prompt reply and suggestions.

                                I have reconfigured Essbase itself and stop and start all the services, but no luck... After that i reconfigured entire EPM itself, the essbase is working fine now.... I didn't take any backup of EPM, that is the mistake i did...

                                Actually for this issue, the Oracle-support recommended the solution to replace the existing working OPMN.xml to current one... but I dont have the existing backup ):...

                                I am pasting the OPMN.xml - old one.... Can you please figure the change, that will useful for me in future...

                                <?xml version="1.0" encoding="UTF-8" standalone="no"?><opmn xmlns="http://www.oracle.com/ias-instance">
                                <log comp="internal;ons;pm" rotation-size="1500000"/>
                                <debug comp="" rotation-size="1500000"/>
                                <notification-server interface="any">
                                <ipaddr remote="ta3"/>
                                <port local="6721" remote="6722"/>
                                <ssl enabled="true" wallet-file="C:\Oracle\Middleware\user_projects\epmsystem1\config\OPMN\opmn\wallet"/>
                                <module path="$ORACLE_HOME/opmn/lib/libopmnohs">
                                <module-id id="OHS2"/>
                                <module path="$ORACLE_HOME/opmn/lib/libopmncustom">
                                <module-id id="CUSTOM"/>
                                <module path="$ORACLE_HOME/opmn/lib/libopmnoid">
                                <module-id id="OID"/>
                                <module path="$ORACLE_HOME/opmn/lib/libopmnbi">
                                <module-id id="BIServer"/>
                                <module-id id="BIScheduler"/>
                                <module-id id="BIPresentationServices"/>
                                <module-id id="BIClusterController"/>
                                <module-id id="BIJavaHost"/>
                                <module path="$ORACLE_HOME/opmn/lib/libopmnovd">
                                <module-id id="OVD"/>
                                <module path="$ORACLE_HOME/opmn/lib/libopmnwc">
                                <module-id id="WebCache"/>
                                <module-id id="WebCache-admin"/>
                                <module path="$ORACLE_HOME/opmn/lib/libopmnreports">
                                <module-id id="ReportsServices"/>
                                <module-id id="ReportsBridgeServices"/>
                                <module path="$ORACLE_HOME/opmn/lib/libopmndisco">
                                <module-id id="Disco_ServicesStatus"/>
                                <module-id id="Disco_SessionServer"/>
                                <module-id id="Disco_PreferenceServer"/>
                                <module path="$ORACLE_HOME/opmn/lib/libopmnemagent">
                                <module-id id="EMAGENT"/>
                                <module path="$ORACLE_HOME/opmn/lib/libopmness"><module-id id="ESS"/></module></process-modules>
                                <ias-instance id="EPM_epmsystem1" name="EPM_epmsystem1">
                                <variable id="TEMP" value="C:\Users\Ravi\AppData\Local\Temp"/>
                                <variable id="TMP" value="C:\Users\Ravi\AppData\Local\Temp"/>
                                <ias-component id="Essbase1">
                                <process-type id="EssbaseAgent" module-id="ESS">
                                <variable id="EPM_ORACLE_HOME" value="C:\Oracle\Middleware\EPMSystem11R1"/>
                                <variable id="EPM_ORACLE_INSTANCE" value="C:\Oracle\Middleware\user_projects\epmsystem1"/>
                                <variable id="ESSBASEPATH" value="$EPM_ORACLE_HOME/products/Essbase/EssbaseServer"/>
                                <variable id="ARBORPATH" value="C:\Oracle\Middleware\user_projects\epmsystem1\EssbaseServer\essbaseserver1"/>
                                <variable id="ESSBASEEXE" value="$ESSBASEPATH/bin/ESSBASE"/>
                                <variable id="HYPERION_LOGHOME" value="$EPM_ORACLE_INSTANCE/diagnostics/logs/essbase"/>
                                <variable id="HYPERION_HOME" value="$EPM_ORACLE_HOME"/>
                                <variable id="ORA_NLS10" value="$EPM_ORACLE_HOME/nls/data"/>
                                <variable id="ESSLANG" value="English_UnitedStates.Latin1@Binary"/>
                                <variable id="ESS_JVM_OPTION1" value="-Xmx256M"/>
                                <variable id="ESS_CSS_JVM_OPTION6" value="-Doracle.dms.context=OFF"/>
                                <variable id="ESS_CSS_JVM_OPTION7" value="-Djava.util.logging.config.class=oracle.core.ojdl.logging.LoggingConfiguration"/>
                                <variable append="true" id="PATH" value="$EPM_ORACLE_HOME/common/ODBC-64/Merant/6.1/lib"/>
                                <variable append="true" id="PATH" value="$ESSBASEPATH/bin"/>
                                <variable append="true" id="PATH" value="$EPM_ORACLE_HOME/bin"/>
                                <variable id="ODBCLIBHOME" value="$EPM_ORACLE_HOME/common/ODBC-64/Merant/6.1/lib"/>
                                <variable id="ODBCINI" value="$EPM_ORACLE_HOME/common/ODBC-64/Merant/6.1/odbc.ini"/>
                                <variable id="ODBCINST" value="$EPM_ORACLE_HOME/common/ODBC-64/Merant/6.1/odbcinst.ini"/>
                                <variable id="OPMN_MANAGED_AGENT" value="true"/>
                                <variable id="ORACLE_THREAD_STACKSIZE" value="1048576"/>
                                <variable id="ESSBASE_CLUSTER_NAME" value="EssbaseCluster-1"/>
                                <start retry="2" timeout="600"/>
                                <stop timeout="600"/>
                                <restart retry="2" timeout="600"/>
                                <port id="essbase-port-range" range="32768-33768"/>
                                <process-set id="AGENT" numprocs="1" restart-on-death="false">
                                <category id="start-parameters">
                                <data id="start-executable" value="$ESSBASEEXE"/>
                                <data id="agent-port" value="1423"/>
                                <data id="agent-secure-port" value="6423"/>
                                <data id="start-args" value="-b"/>
                                <data id="agent-port-active" value="true"/>
                                <data id="agent-secure-port-active" value="false"/>
                                <category id="restart-parameters">
                                <data id="restart-executable" value="integrator"/>
                                <category id="ping-parameters">
                                <data id="ping-interval" value="20"/>
                                <data id="ping-timeout" value="20"/>
                                <!-- Audit Loader Setup TODO
                                Update the interval for Audit Loader to control how frequently
                                the Standalone Audit Loader gets invoked (seconds).
                                <rmd interval="315360000" name="AuditLoader">
                                <!-- Audit Loader Setup TODO
                                Before Updating the action snippet below, please update the
                                password in the Secret Store
                                <!-- Audit Loader Setup TODO
                                Update the jdbcString (@%host%:%port%:%sid%)
                                Update the username (%username%)
                                Update the password (%password%) in Secret Store by adding
                                2 more system properties:
                                <action timeout="60" value="exec $ORACLE_HOME/jdk/bin/java -classpath $COMMON_COMPONENTS_HOME/modules/oracle.osdt_11.1.1/osdt_cert.jar$:$COMMON_COMPONENTS_HOME/modules/oracle.osdt_11.1.1/osdt_core.jar$:$ORACLE_HOME/jdbc/lib/ojdbc5.jar$:$COMMON_COMPONENTS_HOME/modules/oracle.iau_11.1.1/fmw_audit.jar$:$COMMON_COMPONENTS_HOME/modules/oracle.pki_11.1.1/oraclepki.jar -Doracle.home=$ORACLE_HOME -Doracle.instance=$ORACLE_INSTANCE -Dauditloader.jdbcString=jdbc:oracle:thin:@%host%:%port%:%sid% -Dauditloader.username=%username% oracle.security.audit.ajl.loader.StandaloneAuditLoader"/>
                                <exception value="exec /bin/echo PERIODICAL CALL FOR Audit Loader FAILED"/>
                                <launch-target id="logquery">
                                <exec path="$ORACLE_HOME/jdk/bin/java"/>
                                <argument value="-classpath"/>
                                <argument value="$COMMON_COMPONENTS_HOME/modules/oracle.odl_11.1.1/ojdl.jar$:$COMMON_COMPONENTS_HOME/modules/oracle.odl_11.1.1/ojdl2.jar"/>
                                <argument value="-Djava.encoding=utf-8"/>
                                <argument value="oracle.as.management.logging.tools.LogQuery"/>
                                <argument value="-i"/>
                                <argument value="$ORACLE_INSTANCE"/>
                                <launch-target id="createcomponent">
                                <exec path="$ORACLE_INSTANCE/bin/opmnctl$BAT_EXT"/>
                                <argument value="createcomponent"/>
                                <launch-target id="deletecomponent">
                                <exec path="$ORACLE_INSTANCE/bin/opmnctl$BAT_EXT"/>
                                <argument value="deletecomponent"/>
                                <launch-target id="reload" reload-timeout="0">
                                <exec path="$ORACLE_INSTANCE/bin/opmnctl$BAT_EXT"/>
                                <argument value="reload"/>

                                • 13. Re: ESSBASE Error - 1030818
                                  Hi All,

                                  Thank you for all your wonderful support...

                                  Finally i have reconfigured the entire EPM system.. Now Essbase is working fine....

                                  • 14. Re: ESSBASE Error - 1030818
                                    Hi Shiva,

                                    <process-set id="AGENT" numprocs="1" restart-on-death="true"> Default value is false..

                                    Hope you are looking for above line in OPMN.xml file. Am i right?

                                    1 2 Previous Next