This discussion is archived
4 Replies Latest reply: Jan 10, 2013 7:40 AM by Ric Van Dyke RSS

AUTOTRACE too much data 3.2.2

Ric Van Dyke Newbie
Currently Being Moderated
I'm using Version 3.2.20.09. When I use the AUTOTRACE option I'm getting "all" the stats from v$mystat. Older version only seemed to show stat that have a non zero (or non-null) value. But in 3.2 you get all the stats form the view of which most are showing a zero (which I suppose might be a null but is being shown as a zero). Also the output is not in any useful order, I assume they are in order based on statistic# which doesn't help when trying to find certain stats.

For example, looking for BUFFER IS PINNED COUNT is much harder then it should be, it's about a quarter of the way thru the stats:

...(151 stats before this)...
Workload Replay: think time     0
Workload Replay: time gain     0
Workload Replay: time loss     0
Workload Replay: user calls     0
active txn count during cleanout     0
application wait time     0
auto extends on undo tablespace     0
background checkpoints completed     0
background checkpoints started     0
background timeouts     0
blocks decrypted     0
blocks encrypted     0
branch node splits     0
buffer is not pinned count     0
buffer is pinned count     0 <------------------------------------Stat I wanted to find
bytes received via SQL*Net from client     346
...(442 stats after this)...

Is there any way to control this behavior?

First off it seems it would be better to just have the stat with non-zero values and second it would be great to have the stats sorted by name.

There is noting in the preferences that helps and I don't know if there might be a config file setting that would help. Thanks for your help.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points