8 Replies Latest reply: Jan 10, 2013 8:03 PM by User9976634-Oracle RSS

    AddMultiPageTIFF for mainframe MRLs !

    893077
      Hi everyone,

      We are using 'AddMultiPageTIFF' rule in Windows and AIX environments and it is functioning - as expected.

      However, when we try to implement this in a MF mrl, the documaker cannot pick the TIFF file in the specified path.

      The steps we followed

      1. Placed our TIFF file in a PDF (with the file extension being removed)
      2. Added the above rule in a section with parameter File('SXXXX.YYY.ZZZZ')
      3. Did a LBYSYNCH to the MF mrl

      We even tried with adding file extensions, all combinations of spacing,apostrophes.
      None of them was picked by Documaker.

      Has anyone done a simiar thing ?
      Any help is greatly appreciated. Many a thanks !

      -Navin
        • 1. Re: AddMultiPageTIFF for mainframe MRLs !
          User9976633-Oracle
          I'm not a mainframe expert but I think you would need a DD name where the PDF file was stored.
          The DD name could be located in the extract file (and mapped to a GVM variable) or perhaps returned from a DAL script such as the following:

          PDFName = "DD:PDF(medfax)"
          RETURN (PDFName);

          Again, not my area of expertise but perhaps it will help (or least spark others to join in).
          • 2. Re: AddMultiPageTIFF for mainframe MRLs !
            user9976546
            Not sure what version you are using, but I'd try AddMultiPageBitmap if you are above 11.3. It uses a different set of code. There are some notes specific to MF environments.
            • 3. Re: AddMultiPageTIFF for mainframe MRLs !
              Gregg M
              Hey everybody,

              Does anybody have any additional information on using AddMultipageBitmap? Navin, did you ever get this to work on z/OS?

              I'm trying to do the same thing. I added a section level rule for AddMultipageBitmap with the following as my options:
              File(DD:TIFFILE(TEST1))

              I put the following in my JCL in both GenData & GenPrint:
              //TIFFILE DD DSN=MY.TIFF.PDS,
              // DISP=SHR

              I see this in my NAFILE after running Gendata following the section to which it was attached:
              J,ADDMULTIPAGEBITMAP,\File(DD:TIFFILE(TEST1))
              G0;0;20400;26400;3;300;0;0;0;0;0;1;0;\DD:TIFFILE(TEST1)*1

              But then I get a bad return code from GenPrint, with the following information in the ERRFILE:
              DM12041: Error : FAP library error: Transaction:<CHARIDIC>, area:<LBYLoadGBM>
              code1:<0>, code2:<0>
              message:<The LOG file named <DD:TIFFILE(TEST1)> cannot be found in the Library <LBYI> or the Workspace tree>.
              DM12041:, Error : FAP library error: Transaction:<CHARIDIC>, area:<FSI.V115.SOURCE(FAPGLBTM),Mar 23 2012 14:42:10,11,5,4,696>
              code1:<0>, code2:<0>
              message:<Cannot load bitmap on this or later page(s) DD:TIFFILE(TEST1)>.

              DM12041, which is explained a "general purpose error", is supposed to be followed by additional DM### error messages...but in this case, it isn't, so that doesn't help at all.

              Anybody got any ideas? I'm not sure what it means by "workspace tree" in this context...I can't put the Tiff in the library as a Logo, since it's a dynamic TIFF only available at run time, etc.

              Thanks,
              Gregg
              • 4. Re: AddMultiPageTIFF for mainframe MRLs !
                User9976633-Oracle
                Adding the following INI settings may help:

                < BitmapLoaders >
                BitmapLoader = TIFF

                < BitmapLoader:TIFF >
                Func = LOGLoadTifFile
                Type = 3
                • 5. Re: AddMultiPageTIFF for mainframe MRLs !
                  Gregg M
                  That appears to have solved my problem. Thank you very much :)

                  Gregg
                  • 6. Re: AddMultiPageTIFF for mainframe MRLs !
                    Gregg M
                    Apparently I spoke too soon. While I no longer get error messages, and it's successfully pulling in 1-page TIFF's, it does not appear to be working correctly for multiple-page TIFF's. I have a 3-page TIFF that I'm now trying to pull in, and it seems to know it's 3 pages long, but my output shows page 1 three times, rather than showing me all three pages of my TIFF, etc.

                    Any ideas?

                    Gregg
                    • 7. Re: AddMultiPageTIFF for mainframe MRLs !
                      Julie Treger-Oracle
                      Hi Greg,

                      I believe you may have found another bug. There currently is a bug open against your original issue and the workaround is what was described by user9976633 .

                      I am currently following up with PD to see if this new issue is part of the original bug, or if it is a new bug all together.

                      Regards,
                      Julie

                      Edited by: user9976581 on Jan 10, 2013 10:18 AM
                      • 8. Re: AddMultiPageTIFF for mainframe MRLs !
                        User9976634-Oracle
                        You might try using the Embed option on the Multipage rule so that Genprint does not have to read from the TIF a second time. That might solve your problem.