4 Replies Latest reply: Jan 16, 2013 12:19 PM by Mark M. RSS

    &APP_SYSDATE

    Mark M.
      Hi all -- we are in the process of upgrading to 4.1 and are hitting kind of odd situation. Some of the applications are using a substitution string (&APP_SYSDATE.) that we can't find documented anywhere. However, it seems to work in 3.1 and does not work (returns null) in 4.1. Is anyone familiar with this string and is there any direct way to invoke the current sysdate/time as a substitution string? We know we can create an item or a computation, etc. as an alternative.

      Thanks/Mark M.
        • 1. Re: &APP_SYSDATE
          Vite DBA
          Hi Mark,

          True, I can't find any reference to APP_SYSDATE in the documentation archives or on google. Could it possibly be an application item or a static application substitution?

          Regards
          Andre
          • 2. Re: &APP_SYSDATE
            Mark M.
            Thanks Andre. I made the same suggestion for them to look there when I also couldn't find anything online. I've not heard back yet. I'll update the forum if they find anything.

            Rgds/Mark M.
            • 3. Re: &APP_SYSDATE
              fac586
              Mark M. wrote:

              is there any direct way to invoke the current sysdate/time as a substitution string?
              The only built-in date substitution string is <tt>SYSDATE_YYYYMMDD</tt>, which obviously doesn't include the time. This suggests that your <tt>APP_SYSDATE</tt> is an application item created for the data and formatting requirements of the application.
              • 4. Re: &APP_SYSDATE
                Mark M.
                Thanks all. Your responses are much appreciated. We never did entirely get to the root cause, but tend to agree it was something locally created. Either way, we implemented alternate code that works in both 3.1 and 4.1 so I'm closing this out as answered.

                Rgds/Mark M.