This discussion is archived
9 Replies Latest reply: Jan 14, 2013 11:07 AM by dz_r RSS

There is no "Start page" in my SQL Developer

dz_r Newbie
Currently Being Moderated
When I'm running "Oracle Developers Day" virtual machine and SQL Developer installed there (on Linux OS), I can see "Start Page" and there is a menu item Help -> Start page.

But when I'm running SQL Developer installed on my computer (version 3.2.20.09, OS: Windows XP) there is no item Help -> Start page in menu.

Is it something wrong with my SQL Developer or "Start page" is just not present in Windows version of SQL Developer?
  • 1. Re: There is no "Start page" in my SQL Developer
    rp0428 Guru
    Currently Being Moderated
    There is nothing wrong. If you want to display it again look under the help menu.
  • 2. Re: There is no "Start page" in my SQL Developer
    Gary Graham Expert
    Currently Being Moderated
    Hi,
    there is no item Help -> Start page in menu
    If you are certain that's the case, then perhaps ...

    1. You did not install SQL Developer into an empty directory? That is a must!
    2. Your user settings got corrupted somehow?
    3. Some plug-in you added / enabled is causing this issue?

    You can easily test the second case by temporarily overriding where SQL Developer looks for the user settings, then restart the product without migrating settings from an earlier installation (if any). Read the following post to see how:
    Re: System Directory

    Regards,
    Gary
    SQL Developer Team
  • 3. Re: There is no "Start page" in my SQL Developer
    dz_r Newbie
    Currently Being Moderated
    There is nothing wrong. If you want to display it again look under the help menu.

    Hi,

    The point is there is no "Start Page" item in the Help menu in my SQL Developer on Windows XP (even after clean installation):

    http://imm.io/SyIy

    And the same Help menu in SQL Developer on Linux:

    http://imm.io/SCi8
  • 4. Re: There is no "Start page" in my SQL Developer
    dz_r Newbie
    Currently Being Moderated
    +1. You did not install SQL Developer into an empty directory? That is a must!+
    +2. Your user settings got corrupted somehow?+
    +3. Some plug-in you added / enabled is causing this issue?+

    Hi,

    I think it is none of the above cases.

    I've installed SQL Developer on 3 different machines (all of them on Windows XP) and on one of them I've tried totally clean installation - there is still no "Start Page" item in the Help menu.

    http://imm.io/SyIy
  • 5. Re: There is no "Start page" in my SQL Developer
    Gary Graham Expert
    Currently Being Moderated
    I also notice that your Tip of the Day option is greyed out. Is it possible that some files in your SQL Developer installation directory are missing or got renamed or corrupted? There is only one other possibility I can think of at this point:

    If I look at my windowinglayout.xml user settings file (on Windows 7) in directory
    C:\Users\<myuserid>\AppData\Roaming\SQL Developer\system3.2.20.09.87\o.ide.11.1.1.4.37.59.48
    I can see a section in the xml that begins with *<state document="startpage* ...

    Make sure the html file referenced there exists in your SQL Developer installation *doc\welcome* directory for your locale (language). For example, I use English. If I rename or delete *welcome.html* in my ...\sqldeveloper\sqldeveloper\doc\welcome\en directory, then the *Start Page* item will not be present in the Help menu.

    Hope this helps,
    Gary
  • 6. Re: There is no "Start page" in my SQL Developer
    dz_r Newbie
    Currently Being Moderated
    In my windowinglayout.xml there is no section "<state document..." and the section "<editorPositions/>" is empty.

    Because my locale is Polish and there is no dedicated Start Page for that language - I think that is the reason why there is no Start Page in my SQL Developer.

    Standalone Data Modeler doesn't support localized Start Page - English version only - and it works fine on my computer.
    I've copied section "<editorPositions>" from Data Modeler settings file to SQL Developer file (changing the path to Start Page respectively) - and there is some kind of success: now Start Page is showing when I am running SQL Developer. But the menu item "Help -> Start Page" is still not visible.
  • 7. Re: There is no "Start page" in my SQL Developer
    dz_r Newbie
    Currently Being Moderated
    Another success: when I've copied folder "sqldeveloper\doc\welcome\en" to "sqldeveloper\doc\welcome\pl" ("pl" is a standard abbreviation for "Polish") - finally "Help->Start Page" menu item is visible in my SQL Developer.

    But "Help -> Tip of the Day" - still is grayed out...
  • 8. Re: There is no "Start page" in my SQL Developer
    Brian Maher Explorer
    Currently Being Moderated
    If the language is not supported then there is no start page and no tip of the day. Your 'pl' locale now has contents [after you copied it from the 'en' directory]; so basically you are running in a 'pl' locael and showing the 'pl' start page which is now in English however tip of the day will only show if the locale is english.
  • 9. Re: There is no "Start page" in my SQL Developer
    dz_r Newbie
    Currently Being Moderated
    If the language is not supported then there is no start page and no tip of the day.

    Suggested solution: If the language is not supported then there is start page and tip of the day in English.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points