6 Replies Latest reply on Jan 11, 2013 9:18 PM by 984425

    JavaFX & Raspberry Pi

      Are there any way to run Javafx on a Raspberry Pi?

      I've tried with oracle's SDK for ARM architecture and it cause errors during the instalation in a Raspbian wheezy distro.

      Can anyone give me some information of the way to run it or when it could be supported?

        • 1. Re: JavaFX & Raspberry Pi
          I don't knwo what your specific problem is but as far as I know JavaFX runs on Raspberry Pi. The web is full of corresponding links. Look here for example:

          • 2. Re: JavaFX & Raspberry Pi
            I think the JavaFX for ARM public preview only supports the Beagleboard, not the Pi. There is a JavaFX build usable on the Pi, but I think at the moment it is only available to people signed up as an Oracle partner. I believe a forthcoming beta release of JavaFX for ARM will support a wider range of hardware. I do not think there is any public schedule of when such a beta release might be made available and I do not know the date either.
            • 3. Re: JavaFX & Raspberry Pi
              A public JavaFX preview distribution for Raspberry Pi was released today.

              Download: http://jdk8.java.net/fxarmpreview/
              Docs: http://jdk8.java.net/fxarmpreview/javafx-arm-developer-preview.html
              Forum Post at RaspberryPI.org: http://www.raspberrypi.org/phpBB3/viewtopic.php?f=81&t=26110

              Docs include instructions for execution on a Raspbian wheezy distro.

              Here's a DZone link to a related blog post that Stephen Chin wrote, entitled JavaFX on Raspberry Pi – 3 Easy Steps:

              From: http://mail.openjdk.java.net/pipermail/openjfx-dev/2012-December/005017.html
              • 4. Re: JavaFX & Raspberry Pi
                I have installed Java 8 on my Raspberry PI (running Raspbian)
                I downloaded a JavaFX example program (HelloJavaFX2) and ran it successfully
                under Java 8 on my PC.
                I then transfered it to the PI and ran it.
                The first atttempt failed as it needed a path to jfxrt.jar
                Fixing that, it then failed -
                java.lang.RuntimeException: java.lang.UnsatisfiedLinkError: Can't load library:
                The library libglass.so is not in jdk1.8.0

                The solution to this problem -

                Searching the web I found the following site -
                The article states -
                * jfxrt.jar is not on the classpath by default (yet). So be sure to include it!

                * -Djavafx.platform=eglfb must be specified. If not, it won’t run.

                I ran my java fx test with -Djavafx.platform=eglfb and it started to work.

                I now get -
                ES2Pipeline: OpenGL ES 2.0 embedded device detected
                1857463325: glGetError 0x500

                The PI forum think this is a problem caused by the type of Mouse !

                I have tried several different mice and keyboards - still
                fails. I have tried other examples - they fail.

                I am developing my FX software on my PC until someone finds a solution (work

                • 5. Re: JavaFX & Raspberry Pi
                  Don, the error you are seeing is not fatal and JavaFX should be continuing to run. If you are not seeing anything, I wonder if maybe you are using a remote X connection or VNC. JavaFX writes directly to the display framebuffer, so unless you have a screen connected directly to the Pi you won't see anything. Could this be the problem?

                  • 6. Re: JavaFX & Raspberry Pi
                    Tnx Daniel, that was exactly my problem too. I now see the clock on my TV screen hooked up to the pi ...