7 Replies Latest reply on Jan 29, 2013 9:28 PM by 984398

    Cannot discover iscsi storage

      I cannot successfully discover an iscsi lun on our network using ovm 3.1. When I enter the required information for the discovery all that appears in the list is my Oracle Virtual Server regardless of the ip address and other info I enter in the previous step.
      I am able to establish an active session with the storage from the ovm server itself. (iscsiadm -m session)

      Edited by: 981395 on Jan 11, 2013 10:33 AM
        • 1. Re: Cannot discover iscsi storage
          Please check the volume which is shared to VM Server again related to Security on Volume (LUN), then type command as below:

          #iscsiadm -m discovery -t sendtargets -p ip_of_storage

          #service iscsi restart

          check disk

          #cat /proc/partition

          Good luck,

          • 2. Re: Cannot discover iscsi storage
            I have set permissions to the LUN on openfiler to allow everything with no luck.

            Here is the result of /proc/patritions:

            8 0 999161856 sda
            8 1 512000 sda1
            8 2 998648832 sda2
            252 0 52428800 dm-0
            252 1 8265728 dm-1
            252 2 937951232 dm-2
            8 16 6442450944 sdb
            8 32 6442450944 sdc

            sdb and sdc is the iscsi drive (It appears twice as expected, once from the regular IP and the second is from the shared IP.)

            In the OracleVM manager GUI I still only see the single test server I have running OracleVM Server 3.1.1. I can even enter an invalid ip address such as "4" under "Access Information" on the Discover SAN Server page. The result is always only the OracleVM Server.

            I am correct in expecting to see my iscsi server there right?

            Edited by: Ranj on Jan 14, 2013 1:00 PM
            • 3. Re: Cannot discover iscsi storage
              don't know if it is related wanted to test on my machine but having issues with lab setup

              i had the issue that i could not see the iscsi luns ...

              i googled quite a bit and found this link


              the guy says that his iscsi discovery issues where solved after staring multipathd

              unfortunately i again have the
              "     Exception starting xend (Broken capability chain: 0000:0c:00.0 " issue as reported earlier

              so i cannot test ;-(

              • 4. Re: Cannot discover iscsi storage
                Philippe, thank you.

                I also saw that article. Just starting the multipathd service with its default settings as described did not fix my issue. Do I need to configure multipathd in order for it to work? If so, can you point me in the right direction, since most of what I have read about it is beyond my skill level.
                • 5. Re: Cannot discover iscsi storage

                  sorry have similar issues ;-(
                  still not sure in my case if it is the iscsi box ( a small readynas ) or something else, once i find something i will post it

                  • 6. Re: Cannot discover iscsi storage
                    I "upgraded" my vm manager to the 3.2 beta. Still have the same issue.
                    My iscsi server is being used for other things in the organization. This leads me to believe it is properly configured.
                    • 7. Re: Cannot discover iscsi storage
                      I now officially have 3.2 installed (no longer beta). What I noticed is that before discovering any Oracle virtual servers there is no iscsi plug-in available to choose from when discovering storage? Am I making sense? In other words; You can't discover storage before you have discovered a server. Since I can't discover any server besides my Oracle virtual server (such as my Openfiler SAN). How am I to use it for storage since the plug-in seem to be related to the discovered servers.
                      I must be entirely missing something obvious here. All the blogs, videos, posts, even Oracle's documentation make it seem so easy. Just discover your virtual servers and iscsi lun and off you go. What am I missing?
                      This thing has been a headache from day one!