1 Reply Latest reply: Jan 17, 2013 10:31 AM by damorgan RSS

    ASM cluster devices went missing after dropping ASM data disks


      I am a Linux system admin. Need help in below ASM disk issue...

      I have deleted few disks which were marked for data and redo. aftrer deleting those disks, the cluster devices (vote disks) also went off. what could be wrong here

      after doing oracle asm delete disk < data disk1...8>

      did oracleasm scandisks

      then it shows the below

      Reloading disk partitions: done
      Cleaning any stale ASM disks...
      Cleaning disk "GRID_NPRD_109_CL_A_1G_01"
      Cleaning disk "GRID_NPRD_109_CL_A_1G_02"
      Cleaning disk "GRID_NPRD_109_CL_B_1G_01"

      The above 3 are vote disks, I have not deleted them!

      when I do oracleasm querydisk -p on them, it shows the below

      oracleasm querydisk -p GRID_NPRD_109_CL_A_1G_01
      Disk "GRID_NPRD_109_CL_A_1G_01" defines a device with no label

      please help me here.. the GRID installation is performed by DBAs and I need to bring back these devices without initializing them.

        • 1. Re: ASM cluster devices went missing after dropping ASM data disks
          Welcome to the forums.

          What could be wrong here is that you deleted some ASM disks. Why did you do it? We don't know.

          Other things we don't know from your inquiry.
          version number
          code you ran
          justification for what you did
          log file output
          information we could use to determine whether those disks were is use or required

          My read on your post is "I did something wrong on some system and have no idea what I did please help me keep my job."

          Fair enough: Open an SR with MyOracleSupport.