6 Replies Latest reply: Mar 18, 2013 7:44 AM by IdrisAli RSS

    Help Needed , Invoking TCA API on EBS  [11.5.10 to 12 ] using BPEL Process

    918673
      Hi All,


      We are trying to create an organization using the TCA API from a BPEL Process , We can see that the organization gets created and we get the values in response .

      Please find below the request / response from the TCA API .


      <messages>
      <Invoke_CreateORG_createORG_InputVariable>
      <part name="InputParameters" >
      <InputParameters>
      <P_CUST_ACCOUNT_REC>
      <ACCOUNT_NAME>TEST_ACCOUNT_CREATION</ACCOUNT_NAME>
      <CREATED_BY_MODULE>SOA_TCA_API</CREATED_BY_MODULE>
      </P_CUST_ACCOUNT_REC>
      <P_ORGANIZATION_REC>
      <ORGANIZATION_NAME>TEST_ORG_CREATION</ORGANIZATION_NAME>
      <CREATED_BY_MODULE>SOA_TCA_API</CREATED_BY_MODULE>
      </P_ORGANIZATION_REC>
      </InputParameters>
      </part>
      </Invoke_CreateORG_createORG_InputVariable>
      <Invoke_CreateORG_createORG_OutputVariable>
      <part name="OutputParameters" >
      <OutputParameters>
      <X_CUST_ACCOUNT_ID>1100328</X_CUST_ACCOUNT_ID>
      <X_ACCOUNT_NUMBER>81549</X_ACCOUNT_NUMBER>
      <X_PARTY_ID>2357592</X_PARTY_ID>
      <X_PARTY_NUMBER>86664</X_PARTY_NUMBER>
      <X_PROFILE_ID>969846</X_PROFILE_ID>
      <X_RETURN_STATUS>S</X_RETURN_STATUS>
      <X_MSG_COUNT>0</X_MSG_COUNT>
      <X_MSG_DATA xsi:nil="true" />
      </OutputParameters>
      </part>
      </Invoke_CreateORG_createORG_OutputVariable>
      </messages>


      However , When we look into the UI ( Web login) we are unable to find the entry even after querying in many ways .

      Is it the exepcted behaviour . or am i doing any thing wrong.


      Cheers,
      Lakshmi