This discussion is archived
5 Replies Latest reply: Jan 23, 2013 3:04 AM by Voudas75 RSS

Oracle XE 11g homepage not displaying

985727 Newbie
Currently Being Moderated
I have been searching for a solution to my problem for about 2 hours on this forum but none seems to be working, this is my last attempt before I go for re installation.
I today installed Oracle XE 11g Release 2 through its installation wizard and it went fine. The trouble I seem to be having is that I can't open the browser homepage.
The browsers are giving me the error: "cannot establish a connection to the server at 127.0.0.1:8080"

I am on Windows 7 32-bit and i have downloaded & installed the XE for the same.

From reading all the threads on the forum I gathered that some info might be needed before my question is answered. So are the results from various commands that I have run which all the threads asked for.

1)
C:\Users\lenove> netstat -nao | find "8080"
No result for this one

2)
C:\Users\lenovo> lsnrctl status

LSNRCTL for 32-bit Windows: Version 11.2.0.2.0 - Production on 18-JAN-2013 16:46:43

Copyright (c) 1991, 2010, Oracle.  All rights reserved.

Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC1)))
STATUS of the LISTENER
------------------------
Alias                     LISTENER
Version                   TNSLSNR for 32-bit Windows: Version 11.2.0.2.0 - Produ
ction
Start Date                18-JAN-2013 16:18:54
Uptime                    0 days 0 hr. 27 min. 52 sec
Trace Level               off
Security                  ON: Local OS Authentication
SNMP                      OFF
Default Service           XE
Listener Parameter File   C:\oracle\oraclexe\app\oracle\product\11.2.0\server\ne
twork\admin\listener.ora
Listener Log File         C:\oracle\oraclexe\app\oracle\diag\tnslsnr\Voldemort\l
istener\alert\log.xml
Listening Endpoints Summary...
  (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\\.\pipe\EXTPROC1ipc)))
  (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=Voldemort)(PORT=1521)))
Services Summary...
Service "CLRExtProc" has 1 instance(s).
  Instance "CLRExtProc", status UNKNOWN, has 1 handler(s) for this service...
Service "PLSExtProc" has 1 instance(s).
  Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
Service "xe" has 1 instance(s).
  Instance "xe", status READY, has 1 handler(s) for this service...
The command completed successfully
3)
SQL> SELECT dbms_xdb.gethttpport FROM dual;
SP2-0640 : Not Connected
4)
Contents of oraclexe/app/oracle/product/11.20/server/network/ADMIN/listener.ora (oraclexe is the default installation directory suggested by the Installation Wizard)
SID_LIST_LISTENER =
  (SID_LIST =
    (SID_DESC =
      (SID_NAME = PLSExtProc)
      (ORACLE_HOME = C:\oracle\oraclexe\app\oracle\product\11.2.0\server)
      (PROGRAM = extproc)
    )
    (SID_DESC =
      (SID_NAME = CLRExtProc)
      (ORACLE_HOME = C:\oracle\oraclexe\app\oracle\product\11.2.0\server)
      (PROGRAM = extproc)
    )
  )

LISTENER =
  (DESCRIPTION_LIST =
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
      (ADDRESS = (PROTOCOL = TCP)(HOST = Voldemort)(PORT = 1521))
    )
  )

DEFAULT_SERVICE_LISTENER = (XE)
I tried using both chrome and firefox (latest versions of both) but still couldn't get it.
Note: This is my first attempt at oracle so I was a bit wary of trying every solution suggested by the threads, hence my own thread.

Thanx in advance!

Edited by: 982724 on Jan 18, 2013 4:09 AM
  • 1. Re: Oracle XE 11g homepage not displaying
    Niket Kumar Pro
    Currently Being Moderated
    i have tried too but its not working....


    you can use sql developer for connecting to your xe database....
    its freely available on oracle

    http://docs.oracle.com/cd/E17781_01/admin.112/e18585/toc.htm#BJFIIBBD
  • 2. Re: Oracle XE 11g homepage not displaying
    Harsh_v Newbie
    Currently Being Moderated
    solution 1= change line sequence first in listener.ora file. like this

    (ADDRESS = (PROTOCOL = TCP)(HOST = Voldemort)(PORT = 1521))
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))

    SID_LIST_LISTENER =
      (SID_LIST =
        (SID_DESC =
          (SID_NAME = PLSExtProc)
          (ORACLE_HOME = C:\oracle\oraclexe\app\oracle\product\11.2.0\server)
          (PROGRAM = extproc)
        )
        (SID_DESC =
          (SID_NAME = CLRExtProc)
          (ORACLE_HOME = C:\oracle\oraclexe\app\oracle\product\11.2.0\server)
          (PROGRAM = extproc)
        )
      )
     
    LISTENER =
      (DESCRIPTION_LIST =
        (DESCRIPTION =
          (ADDRESS = (PROTOCOL = TCP)(HOST = Voldemort)(PORT = 1521))
          (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
        )
      )
     
    DEFAULT_SERVICE_LISTENER = (XE)
    solution 2 => if solution 1 is not work then try this

    SQL> alter system set local_listener='(ADDRESS=(PROTOCOL=tcp)(HOST=Voldemort)(PORT=1521))' scope=both;
    
    System altered.
    
    SQL> show parameter LOCAL_LISTENE
    
    NAME                                 TYPE        VALUE
    ------------------------------------ ----------- ------------------------------
    local_listener                       string      (ADDRESS=(PROTOCOL=tcp)(HOST=
                                                     Voldemort)(PORT=1521))
  • 3. Re: Oracle XE 11g homepage not displaying
    985727 Newbie
    Currently Being Moderated
    I also cannot connect to my database through SQL command line either. I am getting
    SP2-0640 : Not connected
    when I try any command and
    ORA-01033: ORACLE initialization or shutdown in progress
    when I try to connect as SYSTEM

    Does your answer still holds in these conditions?
  • 4. Re: Oracle XE 11g homepage not displaying
    orafad Oracle ACE
    Currently Being Moderated
    Surender Thakran wrote:
    Listening Endpoints Summary...
    (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\\.\pipe\EXTPROC1ipc)))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=Voldemort)(PORT=1521)))
    Services Summary...
    8080 endpoint is missing from above output.

    But service and db instance is available.
    Service "xe" has 1 instance(s).
    Instance "xe", status READY, has 1 handler(s) for this service...
    The command completed successfully
    Simple thing to try:

    stop listener

    rename listener.ora

    start listener (now default listener parameter settings will apply)


    Run another status check - lsnrctl stat.
  • 5. Re: Oracle XE 11g homepage not displaying
    Voudas75 Newbie
    Currently Being Moderated
    Hello ,

    I had a similar issue .
    Listener.ora is the correct one but you have to pay attention on the HostName used.
    If you ping the hostname (Voldemort ) do you get a reply ?
    Ensure that the hostname alias is accesible and then restart not only the listener but the oracle instance as well

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points