This discussion is archived
6 Replies Latest reply: Feb 3, 2013 4:20 AM by Osama_Mustafa RSS

export command error

985942 Newbie
Currently Being Moderated
hi
everyone

I am very new to this field,since 20 days i am having one problem in my databases,i have 2 database in my windows server environment ,recently i have upgrade my both the database from 10g to 11g.Why i upgrade means in 10g i am getting error ora-07445 access violation,in my alertlog file (when iam going to take full database backup through export getting this error in log file too and export stops in middle with error) so i thought to apply the patch,but with discussion with my manager and team, we all thought this is the time to upgrade so we changed to 11g
then 11g upgrade is 100% successfully completed, to verify the export on 11g ,i thought to take logical backup of my 2 database's
C:\Users\Administrator>exp system/password@tnsname file=full_05_1_2013.dmp log=05_1_2013.log full=y

Export: Release 11.2.0.1.0 - Production on Sat Jan 19 09:18:06 2013

Copyright (c) 1982, 2009, Oracle and/or its affiliates. All rights reserved.

Connected to: Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production
With the Partitioning, OLAP, Data Mining and Real Application Testing options
Export done in WE8ISO8859P1 character set and AL16UTF16 NCHAR character set
server uses AR8MSWIN1256 character set (possible charset conversion)

About to export the entire database ...
. exporting tablespace definitions
. exporting profiles
. exporting user definitions
. exporting roles
. exporting resource costs
. exporting rollback segment definitions
. exporting database links
. exporting sequence numbers
. exporting directory aliases
. exporting context namespaces
. exporting foreign function library names
. exporting PUBLIC type synonyms
. exporting private type synonyms
. exporting object type definitions
. exporting system procedural objects and actions,
.
.
.
what happening here is it just coming to this point and stopping here for hours............more than 10 hours (I have to kiill this session manually).I tried with single user its working but when i take full backup of database export , then it not working,,, i have cross check every possibilities by giving full privileges,space check,and many other but no solution, i was unable to take full backup ,(but i can take single user backup)
i have even applied bundle patch (Oracle® Database Server Version 11.2.0.1 Patch 16) 100% successfully
Bundle Patch Update Note
Release 11.2.0.1 for Microsoft Windows (x64)
Released: November, 2011
NOTE:___one more twist here is , when i bounce the database then i can take full database backup with out error and warnings for 6 to 7 times then again at 8th time its again stopping at above point.......................................................(when i need full logical backup again i need to bounce the db)
what for its stopping here, why it is not going forward,,, its issue with both the database's same,
NOTE:ERROR IN MY ALERTLOG FILE AND TRACEFILE IS
trace file d:\app\admin\diag\rdbms\memfa\memfa\trace\memfa_j000_7844.trc
Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production
With the Partitioning, OLAP, Data Mining and Real Application Testing options
Windows NT Version V6.0 Service Pack 2
CPU : 16 - type 8664, 16 Physical Cores
Process Affinity : 0x0x0000000000000000
Memory (Avail/Total): Ph:1148M/16379M, Ph+PgF:17118M/32914M
Instance name: memfa
Redo thread mounted by this instance: 1
Oracle process number: 22
Windows thread id: 7844, image: ORACLE.EXE (J000)

*** 2013-01-17 12:00:00.124
*** SESSION ID:(196.16104) 2013-01-17 12:00:00.124
*** CLIENT ID:() 2013-01-17 12:00:00.124
*** SERVICE NAME:(SYS$USERS) 2013-01-17 12:00:00.124
*** MODULE NAME:(DBMS_SCHEDULER) 2013-01-17 12:00:00.124
*** ACTION NAME:(PURGE_LOG) 2013-01-17 12:00:00.124

purge queue_table SYS.SCHEDULER_FILEWATCHER_QT
purge queue_table SYS.SCHEDULER$_EVENT_QTAB

alertlogfile___________________________
Thread 1 cannot allocate new log, sequence 123
Private strand flush not complete
Current log# 4 seq# 122 mem# 0: D:\APP\ADMIN\ORADATA\memfa\REDO04.LOG
Thread 1 advanced to log sequence 123 (LGWR switch)
Current log# 5 seq# 123 mem# 0: D:\APP\ADMIN\ORADATA\memfa\REDO05.LOG

already i have change my redo log to 50 to 500 each(3) and increase retention time too
i have tried for more than 50 time by running full database export command ,but its not working ,sometimes 24 hours till at that point only(if i bounce the both the database's then,full database export completes in 9 min(successfully without error and without warnings
)
these are very new databases size nearly 8gb each
please assist/help me in solving this issue,
  • 1. Re: export command error
    Osama_Mustafa Oracle ACE
    Currently Being Moderated
    ora-07445
    You need go to https://support.oracle.com --> Document number --> ORA-600/ORA-7445/ORA-700 Error Look-up Tool [ID 153788.1]

    if there's nothing match with your error, You need to Open SR ,

    note : you should make sure you don't have any error before upgrade.
  • 2. Re: export command error
    Srini Chavali-Oracle Oracle ACE Director
    Currently Being Moderated
    Original exp is desupported in 11gR2 - http://docs.oracle.com/cd/E11882_01/server.112/e22490/original_export.htm#BABBHCIE

    You should be using expdp - http://docs.oracle.com/cd/E11882_01/server.112/e22490/dp_export.htm#i1007466

    Pl also note that exports are not backups - you should be using RMAN - http://docs.oracle.com/cd/E11882_01/backup.112/e10642/rcmintro.htm#CHDBHGGE

    HTH
    Srini
  • 3. Re: export command error
    TSharma-Oracle Guru
    Currently Being Moderated
    Please do the following to find out why your exp is hanging:

    +*<moderator edit - deleted contents of MOS Doc 1154365.1 - pl do NOT post such content - it is a violation of your Support agreement - pl only post the MOS Doc number>*+                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   
  • 4. Re: export command error
    985942 Newbie
    Currently Being Moderated
    first of all sorry for long time feedback, actually as you said ora-07445 is bug, i knew that because of that only i have upgraded from 10g to 11g ,know i dont have any error in alertlog file ,know iam not getting error like ora-07445,ora-00600,ora-03113, (previously i had this errors in 10g)
    when i run the script/manual it just stopping at the above point for hours,(no any error any where)
    i tried many solutions no effect,do any one had any idea what cause it stopping their, iam sure it is not bug
    might be it is o/s problem or some tuning should be done
  • 5. Re: export command error
    Srini Chavali-Oracle Oracle ACE Director
    Currently Being Moderated
    Have you tried expdp ? Original export is desupported in 11gR2 - pl see my link above

    HTH
    Srini
  • 6. Re: export command error
    Osama_Mustafa Oracle ACE
    Currently Being Moderated
    i tried many solutions no effect,do any one had any idea what cause it stopping their, iam sure it is not bug
    What solutions That you have tired ?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points