0 Replies Latest reply on Jan 21, 2013 3:43 AM by utoledodba

    relinking forms executables results in "No rule to make target"

      In the course of installing Forms on weblogic 11gR1 (10.3.4), I ran into an issue after installing patch p9473270 (refer to Oracle Doc ID 1276725.1). The ERP system vendor recommends relinking the forms executables after applying this patch with the following commands:

      Relink the Oracle forms binaries:
      cd $ORACLE_HOME/forms/lib
      make -f ins_forms.mk frmcmp_install
      make –f ins_forms.mk frmbld_install
      make –f ins_forms.mk frmcmpb_install
      make –f ins_forms.mk frmweb_install

      The second command resulted in an error:

      $ make –f ins_forms.mk frmbld_install
      make: *** No rule to make target `–f'. Stop.

      After researching this issue, I tried the following command :

      $ relink forms

      This successfully relinked all forms executables.

      -rwx------ 1 oracle dba 12510433 Jan 20 20:11 frmcmp
      -rwx------ 1 oracle dba 20547 Jan 20 20:11 frmctrl
      -rwx------ 1 oracle dba 13721638 Jan 20 20:11 frmcmp_batch
      -rwx------ 1 oracle dba 12510975 Jan 20 20:11 frmbld
      -rwx------ 1 oracle dba 15275747 Jan 20 20:11 frmweb

      Any thoughts on the usage of "relink forms" vs. the make command? Or why I was encountering the error " No rule to make target"?