3 Replies Latest reply: Nov 7, 2013 5:36 AM by Isabelle RSS

    Data Loading Wizard loses Column Mapping

    850667
      I created pages of APEX page type "Data Loading." They are being used to populate Staging tables and worked terrific in my existing environment. However; I migrated the DB using export and imported it into a new environment. Similarly, I exported my APEX Application and imported it into the new environment. It appears that the second page of Data Loading Wizard has lost the mapping of which table it is loading into. On every column in the second page the only option for the column name is "Do Not Load". What do I need to move over, so that my Data Loading Wizard pages remembers the column names for the table they were mapped to in the old environment?
        • 1. Re: Data Loading Wizard loses Column Mapping
          Paul Broughton
          Hi David,

          You didn't mention what version of APEX you are using. Their was an issue in 4.1 in the export file where the owner wasn't being updated:
          wwv_flow_api.create_load_table( 
          p_id =>3570143708960669327+ wwv_flow_api.g_id_offset,
          p_flow_id => wwv_flow.g_flow_id,
          p_name =>'Load Employees',
          p_owner =>'PAUL',
          p_table_name =>'EMP',
          p_unique_column_1 =>'EMPNO',
          p_is_uk1_case_sensitive =>'N',
          p_unique_column_2 =>'',
          p_is_uk2_case_sensitive =>'N',
          p_unique_column_3 =>'',
          p_is_uk3_case_sensitive =>'N',
          p_wizard_page_ids =>'',
          p_comments =>'');
          Try modifying the p_owner =>'PAUL' line in your export file and change it to the name of the schema your importing it into.

          Thanks

          Paul
          • 2. Re: Data Loading Wizard loses Column Mapping
            850667
            Worked. Thanks!

            Is there a way to patch 4.1 to fix this, without having to migrate to 4.2?

            Edited by: DavidB on Jan 22, 2013 4:15 PM
            • 3. Re: Data Loading Wizard loses Column Mapping
              Isabelle

              Thanks for the solution, Paul!

              I ran into this issue recently and had no idea why this was happening but luckily could resolve the issue by using Paul's method above.

               

              Looks like this has not been fixed in 4.2 yet...

               

              Kind regards,

              Isabelle