This discussion is archived
7 Replies Latest reply: Jan 23, 2013 12:46 AM by Johnny123 RSS

Installing ASM silently, default data group created with def au size

Johnny123 Newbie
Currently Being Moderated
Hello everyone

We are heading towards ASM (grid infrastructure 11.2.0.3) and i'm in progress of automating the process and things are going very well, but I have an issue with how things is configured.

I install the software with:
/opt/grid/tmp/grid/./runInstaller -responsefile /home/grid/grid.rsp -silent
And I have specified config for stand alone server and also specified au size 4 in the response file. this seems to be ignored whatever I do.

root.sh performs fine and it asks for the configtoolall command which requires some response file with some passwords in it.

I specified the following in the responsefile:
oracle.assistants.asm|S_ASMPASSWORD=Test1234 (for testing ofcourse)

and then run /opt/grid/asm_11.2/cfgtoollogs/configToolAllCommands RESPONSE_FILE=/home/grid/cfgrsp.properties
Now it setups network with listener and everything, including running asmca for me..That's nice, but it ignore the specified option of au size 4 and creates it with size 1 instead.

Tried to find a workaround but found none except installing "software only" and doing the config stuff myself.

Apreciate any help.

Sincerely
Johnny
  • 1. Re: Installing ASM silently, default data group created with def au size
    Victor Armbrust Oracle ACE
    Currently Being Moderated
    Are you trying to use AU 4MB for your OCR diskgroup? If you plan to use in your DATA diskgroup (which is much more common), you can set it on later diskgroup creation.

    Have you look at this thread?
    AU size criteria with Oracle 11gR2

    Victor
  • 2. Re: Installing ASM silently, default data group created with def au size
    Johnny123 Newbie
    Currently Being Moderated
    Thank you for your reply and the link, was a good read.

    What i'm trying to do is to get +DATA set to 4 mb AU size, but the config assistant does this for me , but is using default 1 mb.
    We are using external redundancy (SAN) so we have no +OCR group. Or is it recommended to create a diskgroup just for the ASM stuff?

    Sincerely
    Johnny
  • 3. Re: Installing ASM silently, default data group created with def au size
    Johnny123 Newbie
    Currently Being Moderated
    Sorry for the double post but I tried installing using the GUI and the same happens then, I select au size 4 for +DATA and it ignores the value and sets it to 1mb.                                                                                                                                                                                                                                                                                                                                       
  • 4. Re: Installing ASM silently, default data group created with def au size
    Victor Armbrust Oracle ACE
    Currently Being Moderated
    Try to create using sqlplus
  • 5. Re: Installing ASM silently, default data group created with def au size
    Johnny123 Newbie
    Currently Being Moderated
    Using sql*plus works just fine to create diskgroups with ausize of my choice, however, the +DATA diskgroup is already created by the asmca that is being run during and cannot be dropped.
    What I would like to do is to get the -ausize parameter during the asmca installation. However it doesn't seem to be any way to change it :(.
  • 6. Re: Installing ASM silently, default data group created with def au size
    Victor Armbrust Oracle ACE
    Currently Being Moderated
    Yes. Put the OCR files (in case of RAC). I never used asmca in order to create my diskgroups with different AUSIZE, I use sqlplus instead.
    Have you looked on MOS?

    Victor
  • 7. Re: Installing ASM silently, default data group created with def au size
    Johnny123 Newbie
    Currently Being Moderated
    Well we are not running RAC in this case, only the ASM part.

    However, I contacted MOS and ended up with bug 14009493 , ID 1517960.1 . So this is a 11.2.0.3 bug that ignores the au_size value specified via oui.
    No fix yet and only workaround is to move all files from the +DATA diskgroup (or whatever you choose for default diskgroup during installation) to another diskgroup, drop the diskgroup and recreate via sqlplus then move the data back.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points