6 Replies Latest reply: Jan 25, 2013 9:45 AM by BK574 RSS

    Database Adapter Polling problem

    BK574
      Hi All,

      The polling option is processing all the rows in a table at a time instead of using polling frequency. I have used an option of update a field (logical delete) where I have initialized unread value='N' and read value='Y'. Now ,the problem is i have to poll a single row from the table for every 60 seconds ( second row should be processed only after 60 seconds), but all the rows are processing at a same time. Can somebody let me know what could be the problem?

      The options that I set in db adapter are:
      Polling Frequency: 60 seconds
      Database &rows per XML Document: 1
      Database Rows per transaction: 1
      JDBC options , Query & Timeout: 60

      Thanks,
        • 1. Re: Database Adapter Polling problem
          Tarak
          Hi,

          Please follow below link. I hope this will solve your issue.

          http://docs.oracle.com/cd/E23943_01/integration.1111/e10231/adptr_db.htm

          Look for below one .

          9.3.8.1.1 Configuring PollingInterval, MaxTransactionSize, and ActivationInstances

          Regards,
          Tarak.
          • 2. Re: Database Adapter Polling problem
            vladodias
            Hi,

            Configure properties MaxTransactionSize=1, MaxRaiseSize=1 and NumberOfThreads=1 in the adapter _db.JCA file...

            If that doesn't work post the contents of your .jca...

            Cheers,
            Vlad
            • 3. Re: Database Adapter Polling problem
              BK574
              Hi Vlad,

              please find the jca file

              <endpoint-activation portType="PollEvent_ptt" operation="receive">
              <activation-spec className="oracle.tip.adapter.db.DBActivationSpec">
              <property name="DescriptorName" value="PollEvent.HolxSrEventData"/>
              <property name="QueryName" value="PollEventSelect"/>
              <property name="MappingsMetaDataURL" value="PollEvent-or-mappings.xml"/>
              <property name="PollingStrategy" value="LogicalDeletePollingStrategy"/>
              <property name="MarkReadColumn" value="PROCESSED_FLAG"/>
              <property name="MarkReadValue" value="Y"/>
              <property name="MarkUnreadValue" value="Yes"/>
              <property name="PollingInterval" value="60"/>
              <property name="MaxRaiseSize" value="1"/>
              <property name="MaxTransactionSize" value="1"/>
              <property name="NumberOfThreads" value="1"/>
              <property name="ReturnSingleResultSet" value="false"/>
              <property name="SequencingColumn" value="INCIDENT_ID"/>
              <property name="DelayCommit" value="true"/>
              </activation-spec>
              </endpoint-activation>
              • 4. Re: Database Adapter Polling problem
                vladodias
                Everything's looking good in the .jca...

                Try configuring activationInstances=1 in composite.xml... Ref this doc... http://docs.oracle.com/cd/E23943_01/admin.1111/e10226/bc_config.htm#r2c1-t15

                Like this...
                <service name="your-service-name-here">
                  <interface.wsdl interface="your-interface-here"/>
                  <binding.jca config="your-jca-file-here.jca">
                    <property name="activationInstances">1</property>
                
                ... (other properties)
                
                  </binding.jca>
                </service>
                Hope this helps...

                Cheers,
                Vlad
                • 5. Re: Database Adapter Polling problem
                  Albin
                  Please refer the below URL this may help you.

                  http://www.albinsblog.com/2012/10/db-adapter-message-throttling-in-oracle.html#.UQI3_fLDiuk


                  Regards
                  Albin I
                  [http://www.albinsblog.com/]
                  • 6. Re: Database Adapter Polling problem
                    BK574
                    Thanks Albin,

                    It is working after setting <property name="RowsPerPollingInterval" value="1"/> inside jca file

                    Thanks once again.