This discussion is archived
4 Replies Latest reply: Jan 28, 2013 11:39 AM by Hussein Sawwan-Oracle RSS

Error Apache has not been designed to serve pages while running as

983528 Newbie
Currently Being Moderated
hi
Error
--> Process (index=1,uid=499219628,pid=17071)
   failed to start a managed process after the maximum retry limit
   Log:
   /d04/applclone/inst/apps/VINTEST_server/logs/ora/10.1.3/opmn/HTTP_Server~1.log
13/01/25 12:33:02 Start process
--------
/d04/applclone/inst/apps/VINTEST_server/ora/10.1.3/Apache/Apache/bin/apachectl startssl: execing httpd
Error:  Apache has not been designed to serve pages while
        running as root.  There are known race conditions that
        will allow any local user to read any file on the system.
        If you still desire to serve pages as root then
        add -DBIG_SECURITY_HOLE to the EXTRA_CFLAGS line in your
        src/Configuration file and rebuild the server.  It is
        strongly suggested that you instead modify the User
        directive in your httpd.conf file to list a non-root
        user.
                                                              112,2-9       Bot
[applclone@server scripts]$ ./adopmnctl.sh status

You are running adopmnctl.sh version 120.6

Checking status of OPMN managed processes...

Processes in Instance: VINTEST_server.server.csacons.com
---------------------------------+--------------------+---------+---------
ias-component                    | process-type       |     pid | status
---------------------------------+--------------------+---------+---------
OC4JGroup:default_group          | OC4J:oafm          |   13120 | Alive
OC4JGroup:default_group          | OC4J:forms         |   13025 | Alive
OC4JGroup:default_group          | OC4J:oacore        |   12907 | Alive
HTTP_Server                      | HTTP_Server        |     N/A | Down


adopmnctl.sh: exiting with status 0

adopmnctl.sh: check the logfile /d04/applclone/inst/apps/VINTEST_server/logs/appl/admin/log/adopmnctl.txt for more information ...

[applclone@server scripts]$
SO HTTP Service is not working.

OS : RHEL 5.x 64 bit
EBS R12.1.3
Kind Regards

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points