9 Replies Latest reply: Jan 28, 2013 2:58 AM by Christian Erlinger RSS

    Forms 10G Runtime not responding

    fs_79
      I have windows 7 Form10G DB 10G.

      Form Runs successfully in IE9 but not responding.

      for example if I press execute query button no data shown but if i click on Title bar and move Form little bit, query execute and data show up.
        • 1. Re: Forms 10G Runtime not responding
          yoonas
          Hi,

          Its not certified yet(may be you could get it working with some tweaks), try on any other certified browsers and see
          http://www.oracle.com/technetwork/developer-tools/forms/clientsod-forms10gr2-097528.html

          Regards
          Yoonas
          • 2. Re: Forms 10G Runtime not responding
            fs_79
            I have tried Mozila as well but same response.
            • 3. Re: Forms 10G Runtime not responding
              yoonas
              you can see from the certification matrix list that later version are supported with sun jre not with jinitiator

              I had problem while running forms (10.1.2.0.2) iexplorer 8 on windows 7.

              This was what had done to get it working (Try if this could help you)


              1. go to Oracle Java Archive website and download Java SE Runtime Environment 6u13 (jre-6u13-windows-i586-p.exe)
              (http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-javase6-419409.html#jre-6u13-oth-JPR)


              2 Install the JRE 6u13 (jre-6u13-windows-i586-p.exe)

              3. Rename the the old jvm.dll file in the (C:\Program Files (x86)\Oracle\JInitiator 1.3.1.21\bin\hotspot) directory

              4. copy the jvm.dll from java jre 6u13 installation directory (C:\Program Files (x86)\Java\jre6\bin\client) to the jinitiator direcotry (C:\Program Files (x86)\Oracle\JInitiator 1.3.1.22\bin\hotspot)

              http://yoonusp.blogspot.com/2013/01/accessing-oracle-application-11i-froms.html


              Regards
              Yoonas

              Edited by: yoonus on Jan 27, 2013 2:57 AM
              • 4. Re: Forms 10G Runtime not responding
                HamidHelal
                yoonus wrote:
                1. go to Oracle Java Archive website and download Java SE Runtime Environment 6u13 (jre-6u13-windows-i586-p.exe)
                (http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-javase6-419409.html#jre-6u13-oth-JPR)
                Why u suggest 6u13 version, where at least 6u32 or higher is available..
                Most advance browser doesn't support 6u13 version.


                Hamid
                • 5. Re: Forms 10G Runtime not responding
                  yoonas
                  Dear Hamid,

                  I did not actually suggest, i just shared what I had done when i had similar issue with iexplorer 8 on windows 7. I have a running pc with the above steps, i did not try other versions so i am not sure the steps i did would work.

                  If op is able to solve with better solutions he can always go for that

                  Regards
                  Yoonas
                  • 6. Re: Forms 10G Runtime not responding
                    fs_79
                    Dears, Thanks for prompt responses.

                    Mater of fact is, I have already followed given steps hence I was able to run Form on non certified platform, I cannot move back to XP or IE8. Here the problem is response time. Forms runtime took almost 3 to 4 minutes to give response after any action.
                    • 7. Re: Forms 10G Runtime not responding
                      HamidHelal
                      fs_79 wrote:
                      Dears, Thanks for prompt responses.

                      Mater of fact is, I have already followed given steps hence I was able to run Form on non certified platform, I cannot move back to XP or IE8. Here the problem is response time. Forms runtime took almost 3 to 4 minutes to give response after any action.
                      Is it development environment or production ?
                      Lower then IE9, does it works perfectly ?

                      What is JRE version ?

                      Is there any firewall or antivirus issue ?


                      Hamid
                      • 8. Re: Forms 10G Runtime not responding
                        fs_79
                        Thanks Hamid for quick reply,

                        its just on my laptop for RND purposes.

                        In Mozilia old version same response. IE not allowed to downgrade in windows 7.

                        disabled firewal and tried different resolutions as well.

                        further I will update you later.

                        Edited by: fs_79 on Jan 27, 2013 10:17 PM
                        • 9. Re: Forms 10G Runtime not responding
                          Christian Erlinger
                          You didn't mention anywhere your java version; judging from your response to applying the hack to replace the jvm.dll (which is not advisable at all) I guess you are running still with JInitiator. This is also not advisable.

                          See here on how to properly configure forms 10gR2 with the Sun JRE: http://www.oracle.com/technetwork/developer-tools/forms/documentation/forms-jre-131772.pdf

                          In addition you should use the latest 1.6 JRE which is 1.6u38. You can download it from here: http://www.oracle.com/technetwork/java/javase/downloads/jre6u38-downloads-1877409.html

                          If it still doesn't work I'd rip out functionality from the form bit by bit and rerun again until you can't reproduce the problem to get down to the real problem...

                          cheers