2 Replies Latest reply on Jan 28, 2013 8:31 AM by Joni Vandenberghe

    two level of tabs - only 1 level shows up

    Tom vd Duin
      Hi all,

      I have an application, previously set up without using tabs, but I added two level of tabs. It looks like everything is fine, but only the standard tabs are on the pages, not the parents.

      Invionment: Apex 4.1, Oracle 10gR2 on Windows 32 bit

      This is what I've done:
      - set the page component default in the theme (26) to 'Two level of tabs, no sidebar'
      - I have a parent tab set ('PTS1')
      - I have 4 parent tabs: PTAB1, PTAB2, PTAB3, PTAB4. All parent tabs have one or more tabs under it and the tab target is the right page.
      - all the tabs have the 'standard tab set' set right, ie PTAB1. All tabs are in parent tab set 'PTS1'
      - alle the pages have page template 'use theme default'. I also tried setting it explicitly to one of the templates with two level of tabs, but with the same result.

      When I open a certain page, I only see the tabs, I don't see the parent tabs! Is there something I forgot to configure?

      Thank in advance,
        • 1. Re: two level of tabs - only 1 level shows up
          Howard (... in Training)
          From what I read, this can be done simply or it can get complex. It seems to be more complex if you are changing from a one-level tab structure to a two-level tab structure. You might do a forum search with ("one-level tab" AND "two-level tab"). Or see this message and the entire thread it's a part of {message:id=1160761}.

          Best regards,
          • 2. Re: two level of tabs - only 1 level shows up
            Joni Vandenberghe
            Ok first go to shared components > Tabs. Select your parent tab set.
            Go to manage tabs. Does every parent tab got at least one subtab? Do they all refer to pages?

            If that's ok go to edit standard tabs and check out the right column. Do all tabs there have a parent tab set? If they don't then edit those that don't have one.

            If that did not solve it go to "Tabs".
            Select your parent tab set PTS1. Check if all your parent tabs are viewable.
            If they aren't then you created your parent tabs under different tab sets and you need to delete those that aren't on the right one.

            I hope you can find a solution here somewhere.