This discussion is archived
3 Replies Latest reply: May 29, 2013 8:57 PM by Gary Graham RSS

Unable to launch the Java Virtual Machine

Verdi Newbie
Currently Being Moderated
OS: Windows 7 64bit

I installed Sql Developer 64bit and placed it in C:\Program Files\sqldeveloper

Then I installed Java JDK and JRE for Windows 64bit in C:\Program Files\Java\jdk1.7.0_11 and C:\Program Files\Java\jre7 respectfully.

When I try to start SQL Developer it prompts me for full path to java.exe file.

I provide it with the path to C:\Program Files\Java\jdk1.7.0_11\bin\java.exe and it fails loading with the error message "The program can't start because MSVCR100.dll is missing from your computer. Try reinstalling the program and fix this problem."
Next it shows the error "Unable to launch the Java Virtual Machine located at path: C:\Program Files\Java\jdk1.7.0_11\jre\bin\server\jvm.dll"

I went to see if jvm.dll really exists and yes it does in the specified path: C:\Program Files\Java\jdk1.7.0_11\jre\bin\server
I went to check if the file msvcr100.dll exists and yes it does in C:\Program Files\Java\jdk1.7.0_11\jre\bin

Does someone know how this problem can be resolved?

Thank you!
  • 1. Re: Unable to launch the Java Virtual Machine
    Gary Graham Expert
    Currently Being Moderated
    Hi,

    Any of the following solutions should work. I personally go with (3) unless I have an explicit requirement to use 64-bit versions.

    1. Copy MSVCR100.dll from your 64-bit Java install into the SQL Developer folder with contains sqldeveloper.conf .
    2. Alter your $PATH variable: append $JAVA_HOME\bin to it. (Assuming a $JAVA_HOME variable has been set correctly)
    3. Download the 32-bit SQL Developer version that already includes a 32-bit JDK. Runs fine on a 64-bit OS.

    Regards,
    Gary
    SQL Developer Team

    Edited by: Gary Graham on Jan 29, 2013 11:26 AM
  • 2. Re: Unable to launch the Java Virtual Machine
    1011409 Newbie
    Currently Being Moderated
    Hi Gary,

    I would prefer a solution along the lines of 2., but despite %JAVA_HOME% being correctly set (to C:\Program Files\Java\jdk1.6.0_43) and having %JAVA_HOME%\bin on my %PATH%, the problem persist.

    (I assume the use of $ in your post is a typo, since environment variables are like %PATH% on Windows, not $PATH. Or are you referring to SQL Developer specific variables?)

    Any thoughts?

    Thanks,
    Peter
  • 3. Re: Unable to launch the Java Virtual Machine
    Gary Graham Expert
    Currently Being Moderated
    Hi Peter,
    I assume the use of $ in your post is a typo
    Yes, just Linux vs Windows forgetfulness on my part.
    despite %JAVA_HOME% being correctly set (to C:\Program Files\Java\jdk1.6.0_43) and having %JAVA_HOME%\bin on my %PATH%
    But I don't think msvcr100.dll ships with Java 6 (in the jdk1.6.0_45\bin directory). It comes with Java 7, since that's where you actually would need it.

    To test this, I intentionally disabled the msvcr100.dll in my 64-bit SQL Developer installation, as well as in the Windows\system32 directory. Next I opened a command window and set the Path variable to contain only
    Path=C:\Windows;C:\Windows\system32
    Running SQL Developer with jdk1.6.0_45 from the same command window worked fine, but switching to jdk1.7.0_21 in the sqldeveloper.conf file required that I change the path to
    Path=C:\Windows;C:\Windows\system32;C:\Program Files\Java\jdk1.7.0_21\bin
    And I hope to have avoided any more typos in this post...

    Cheers,
    Gary

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points