8 Replies Latest reply: Jan 29, 2013 4:02 PM by ngilbert RSS

    EM12c Privileged Host Credential not working

    ngilbert
      Having trouble setting up the privileged host credential.

      This is using Oracle Cloud 12c (12.1.0.2), target host is RedHat 5

      My steps:
      Create a named credential with target type host, credntial type host credentials, applied to specific host target
      Username and password of a user (ngilbert) with sudo rights on the target, set run privilege to Sudo, with Run as = root
      When I hit "Test and Save" I get Authentication Failure, check credential properties.

      Then went to Security->Privilege Delgation, for the target host hit Edit
      For the sudo command /usr/bin/sudo -u %RUNAS% %COMMAND%
      went to target host, logging in with the username and password supplied to the credential, ran '/usr/bin/sudo -u root ls -la', was prompted for password and supplied the password I specified for the credential, command completed successfully.

      In the gcagent.log log on the target I see:
      2013-01-28 10:48:02,523 [1935:F2C3CAF7:HTTP Listener-1935 - /emd/main/ (DispatchRequests OMS@3485@grid.csusm.edu=>[135939889320001])] INFO - >>> Dispatching request: PerformOperationRequest (perl -e exit 0 owner=ngilbert jobId=OMS@3485@grid.csusm.edu=>[135939889320001]) <<<
      2013-01-28 10:48:02,523 [1935:F2C3CAF7] INFO - OMS@3485@grid.csusm.edu=>[135939889320001]
      2013-01-28 10:48:06,539 [1935:F2C3CAF7] WARN - Could not extract PID from NMO
      2013-01-28 10:48:06,558 [1935:F2C3CAF7] INFO - PacketWriter wrote Packet:JobTaskExitPacket[exitCode=7,msg=,nlsid=62]
      2013-01-28 10:48:06,559 [1935:F2C3CAF7] INFO - >>> Reporting exception: oracle.sysman.emSDK.agent.client.exception.PerformOperationException: ERROR: Invalid username and/or password LOG: Local Authentication Failed...Attempt PAM authentication...PAM failed with error: Authentication failure (request id 1) <<<
      oracle.sysman.emSDK.agent.client.exception.PerformOperationException: ERROR: Invalid username and/or password LOG: Local Authentication Failed...Attempt PAM authentication...PAM failed with error: Authentication failure

      I have triple checked the password, so I'm not sure what I'm missing

      Edited by: ngilbert on Jan 28, 2013 11:25 AM