9 Replies Latest reply on Aug 24, 2013 7:31 PM by user11319190

    11G forms cannot call reports via run_report_object

    Mark Reichman Forms/Reports, Windows 7 64-bit, Weblogic 10.3.6

      Asked this question on the reports forum 2 weeks ago no response.

      I have a new install of forms and reports. I am using my 10g fmb and rdf and pll files all recompiled to 11g. So, the forms, reports, plls are all coded correctly and have worked for years as 10g forms. The 11g forms run fine and so does webutil . However, I cannot get the forms to call the reports. I have changed the rwserver.conf file for both the in-process and stand alone servers to point to the reports rdf/rep path. I can call reports from a url and see the report successfully run and also in the report queue, so I know the path is set correctly to the reports. I know run_report_object in the form is returning 0 (zero) and always trying to "getjobid0". The form returns frm-41212: Unable to connect to the report server. I have set my report server name in the default.env file to the in-process server - the form uses this variable to eventually run_report_object. Like I said the form has worked for years as a 10g form calling reports. There has got to be a setting somewhere that I havent done. Any ideas?
        • 1. Re: 11G forms cannot call reports via run_report_object
          Paul M.
          I have set my report server name in the default.env file to the in-process server
          I assume the in-process reports server is running (did you check it ?), but did you try the standalone one ?

          We have exactly your scenario, and exactly your versions (Weblogic and Forms/Reports), with no problems at all (using standalone reports server). The only difference is that we use Linux...
          • 2. Re: 11G forms cannot call reports via run_report_object
            Mark Reichman
            I replaced my hostname with xxxxx for this post. I issue the following urls and I get a web page back from each.


            I completed 'Verifying the Reports Server Environment' at http://docs.oracle.com/cd/E17904_01/bi.1111/b32121/pbr_verify004.htm. All checks out.

            I log into weblogic console and see nothing but green checks and OK for (WSL_FORMS, WLS_REPORTS)

            Like I said I can call a report from a url and I can see the report in the queue. But using run_report_object in forms gives me frm-41213: Unable to connect to the report server rep_wls_reports_xxxxxx_oraforms. Or, RptSvr_xxxxxx_oraforms. I see nothing in the report queue.

            When I do this call via a url, see below, l I can see the report in the queue for server rep_wls_reports_xxxxxx_oraforms. Evidently port 9002 defaults to the in-process server?

            • 3. Re: 11G forms cannot call reports via run_report_object
              Christian Erlinger
              OK, so rep_wls_reports_xxxxxx_oraforms is a standalone reports server, and you are running your reports via run_reports_object on this reports server?

              To test if it works via the URL you could add the name of the reports server in the URL to

              Also if you are running forms/reports in production mode port 9002 is not quite correct, the reports servlet delivers your report via the OHS port, so to rule out some OHS issues I'd retry with the OHS port instead the WLS_REPORTS port just to be sure.

              I have a somewhat similar config (forms with WLS 10.3.6 on 32bit; it previously worked with too) and it works for me.

              also what does
              %ORACLE_INSTANCE%\config\reports\bin\rwdiag -findall
              tell you? Do you find your reports server? A few days ago I had a similar problem in 10g where the reports server returned informations via getserverinfo, but refused to deliver reports, and was also not detectable via rwdiag -findall. The solution there was to configure the naming service instead of broadcasting.

              • 4. Re: 11G forms cannot call reports via run_report_object
                Mark Reichman
                rep_wls_reports_xxxxxx_oraforms is the in-process server. So, what should I be using to connect to the report server from forms?

                rep_wls_reports_xxxxxx_oraforms at port 9002.. Or, rptsvr_xxxxxx_oraforms at port 9002. Or, rptsvr_xxxxxx_oraforms at port 8888?

                C:\Oracle\Middleware_oraforms\oraforms\bin>opmnctl.bat status -l

                Processes in Instance: oraforms
                ias-component | process-type | pid | status | uid | memused | uptime | ports
                emagent_oraforms | EMAGENT | 3344 | Alive | 1756764245 | 48872 | 284:33:06 | N/A
                RptSvr_xxxxxx_oraforms | ReportsServerComp~ | 3424 | Alive | 1756764244 | 193096 | 284:33:03 | N/A
                ohs1 | OHS | 3336 | Alive | 1756764243 | 23512 | 284:33:06 | https:8889,https:8890,http:8888

                C:\Oracle\Middleware_oraforms\oraforms\config\reports\bin>rwdiag -findall

                Reading the rwnetwork.conf from :C:\Oracle\Middleware_oraforms\oraforms\config\R
                Broadcast mechanism used to locate servers
                Channel address = xxx.5.6.7
                Channel port = 14021

                (1) Name = rep_wls_reports_xxxxxx_oraforms : Type = server : Host = xxxxxx.xxxxxx.private
                (2) Name = rptsvr_xxxxxx_oraforms : Type = server : Host = xxxxxx.xxxxxx.private
                • 5. Re: 11G forms cannot call reports via run_report_object
                  Mark Reichman
                  run_report_object is not running the report whether I used port 8888 or 9002 and/or rptsvr_xxxxxxx_oraforms or rep_wls_reports_xxxxxxx_oraforms in any combination.

                  I can use either port on either server and can see the reqport queue and run reports from a url. rptsvr_xxxxxx_oraforms does have an issue connecting to the database. rep_wls_reports_xxxxxxx_oraforms connects to the database fine.
                  • 6. Re: 11G forms cannot call reports via run_report_object
                    Mark Reichman
                    Well.. Basically everything works except run_report_object. This is the sequence of errors I get after calling run_report_object. run_report_object is not doing what it is supposed to do - connect to the report server. Since run_report_objects is a closed api I have no way of figuring out what is wrong or how run_report_object works.

                    1. Run_report_object returns this.. RptSvr_xxxxxx_oraforms_0
                    2. I then get this error. Frm-41213: Unable to connect to report server RptSvr_xxxxxx_oraforms
                    3. report_object_status returns null
                    • 7. Re: 11G forms cannot call reports via run_report_object
                      Christian Erlinger
                      It shouldn't matter (much) if you are running via port 9002 or 8888; I just wanted to rule out problems with apache and mod_wls, but since via the URL both ports are working this shouldn't be a problem.

                      Anyway; maybe an idea is to start from scratch, I'd create a dummy form calling a dummy report via a newly created standalone reports server.
                      I guess you know note 207396.1 How to Run Reports From Forms 9i /10g /11g Using RUN_REPORT_OBJECT as a reference implementation; so I'd build a dummy form upon the code mentioned there just to be sure nothing "old" is in the way from the 10g version. After that create a standalone reports server named dummy or something, configure the source directory and try to run the report on exactly that reports server. If this still fails then...well...

                      • 8. Re: 11G forms cannot call reports via run_report_object

                        I do have almost same problem, but i am using oracle linux 5.9 / 32 bits, with oracle weblogic 10.3.6 and forms/reports (latest version). I also have forms in 10gr2 that worked like charm calling the reports from those forms but when using 11g everything changed i cant call the reports anymore from the ones that used to work on 10g. i am wondenring if u managed to solve your problem somehow?


                        One thing i know oracle has to change fast the way forms are called in the reports there seems to be a lot of problems from users in calling reports from forms the process is not straight away compared to other tools in the market. I think this needs a review from oracle.

                        • 9. Re: 11G forms cannot call reports via run_report_object

                          Hi all,


                          We are facing the same issue on the same scenario explained,anybody have any solution or suggestion to this,i feel Fusion middlware is giving real tough time to the developers.We are in production deployment and everything went well expect the reports running from forms using run_report_object.even i tried to run the reports using a 10g application server deployed from a form deployed it in fusion Middle ware deployment but same error it is giving.


                          any help really appreciable.