This discussion is archived
3 Replies Latest reply: Feb 1, 2013 12:48 AM by 908067 RSS

reboot cause

908067 Newbie
Currently Being Moderated
Hi guys,

I have a Solaris 10 server that got rebooted...Vmcore file created..I am a newbie in this filed, but I tried to analyze the cause of reboot anyway. I used 2 tools to analyze the crash dump and got to 2 different conclusions, so I need help to clarify the real issue.

Using mdb, looks like the panic was created by an Oracle-RAC related process (oprocd.bin):
 ::panicinfo
             cpu                1
          thread      30004243500
         message forced crash dump initiated at user request
          tstate       4400001605
              g1                b
              g2                0
              g3          11f7a44
              g4              6e0
              g5         88000000
              g6                0
              g7      30004243500
              o0          128f9f8
              o1      2a100c619e8
              o2                1
              o3                0
              o4 fffffffffffffff5
              o5             1000
              o6      2a100c610b1
              o7          10701a8
              pc          104abec
             npc          104abf0
               y                0
 30004243500::thread -p
            ADDR             PROC              LWP             CRED
0000030004243500      6001c0f5968      600200659e0      60010025e38
 6001c0f5968::ps -t
S    PID   PPID   PGID    SID    UID      FLAGS             ADDR NAME
R   4864   4707   1118   1118      0 0x4a004000 000006001c0f5968 oprocd.bin
        T     0x30004243500 <TS_ONPROC>
Don't ask me how I ran te above commands, just used a similar info from web :)

Using SCAT, looks like the crash was forced from keyboard (STOP+A):
CAT(vmcore.2/10U)> analyze

core file:      /var/crash/xxxxxx/vmcore.2
user:           Super-User (root:0)
release:        5.10 (64-bit)
version:        Generic_147440-09
machine:        sun4u
node name:      xxxxxxxx
domain:        xxxxx
hw_provider:    Oracle Corporation
system type:    SUNW,Sun-Fire-V240 (UltraSPARC-IIIi)
hostid:         xxxxx
dump_conflags:  0x10000 (DUMP_KERNEL) on /dev/dsk/c1t0d0s1(3.90G)
time of crash:  Wed Jan 30 01:06:32 MST 2013
age of system:  57 days 13 hours 34 minutes 22.61 seconds
panic CPU:      1 (2 CPUs, 8G memory, 1 nodes)
panic string:   forced crash dump initiated at user request


==== system appears to have been Stop-A'ed ====
Of course, the output is longer; if relevant I'll paste here...

Now, which source should I trust?

Thank you!

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points