This discussion is archived
1 2 Previous Next 17 Replies Latest reply: Feb 12, 2013 8:26 AM by 987437 RSS

NoClassDefFoundError when I run a custom doclet from command line

987437 Newbie
Currently Being Moderated
I have a custom Doclet created - SimpleDoclet. I have compiled this file and I have the class and java files in the same dir (oldPack)

When I run this from oldPack directory (where the class and java files are present) :
javadoc -doclet SimpleDoclet -docletpath . -classpath /usr/java/jdk1.6.0_30/lib/tools.jar

I get the following error:
java.lang.NoClassDefFoundError: SimpleDoclet (wrong name: oldPack/SimpleDoclet)
     at java.lang.ClassLoader.defineClass1(Native Method)
     at java.lang.ClassLoader.defineClassCond(
     at java.lang.ClassLoader.defineClass(
     at Method)
     at java.lang.ClassLoader.loadClass(
     at java.lang.ClassLoader.loadClass(
javadoc: error - fatal error
1 error

Tried this with another custom doclet and still gives this error. Any solutions please?
1 2 Previous Next


  • Correct Answers - 10 points
  • Helpful Answers - 5 points