10 Replies Latest reply: Jan 31, 2013 2:57 AM by user10232063 RSS

    Post Installation check for 12.1.1

    user13653962
      i am installing 12.1.1 (32 bit) on oel 5 (32 bit), one of the package gnome-libs-1.4.1.2.90-34.1.i386 for OEL 5 (32 bit) creating an issue at post installation for HTTP server not opening

      when i check the HTTP server status i found
      [oracle@test scripts]$ adapcctl.sh status
      
      You are running adapcctl.sh version 120.7.12010000.2
      
      Checking status of OPMN managed Oracle HTTP Server (OHS) instance ...
      
      Processes in Instance: VIS_test.test.parazelsus.pk
      ---------------------------------+--------------------+---------+---------
      ias-component                    | process-type       |     pid | status  
      ---------------------------------+--------------------+---------+---------
      OC4JGroup:default_group          | OC4J:oafm          |   10722 | Alive   
      OC4JGroup:default_group          | OC4J:forms         |   10654 | Alive   
      OC4JGroup:default_group          | OC4J:oacore        |   10572 | Alive   
      HTTP_Server                      | HTTP_Server        |     N/A | Down    
      Upon checking logfile
      --------
      11/04/18 07:43:44 Start process
      --------
      /appshome/oracle/VIS/inst/apps/VIS_test/ora/10.1.3/Apache/Apache/bin/apachectl startssl: execing httpd
      /appshome/oracle/VIS/apps/tech_st/10.1.3/Apache/Apache/bin/httpd: error while loading shared libraries: libdb.so.2: cannot open shared object file: No such file or directory
      i got a resolution for above issue from metalink 735605.1 to install one of the rpm gnome-libs-1.4.1.2.90-34.1.i386 , when i try to install it i got following dependencies error.

      Missing Dependency: libORBitutil.so.0 is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
      Missing Dependency: ORBit is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
      Missing Dependency: libgdk_imlib.so.1 is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
      Missing Dependency: imlib is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
      Missing Dependency: libORBit.so.0 is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
      Missing Dependency: libIIOP.so.0 is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
      Missing Dependency: libpng.so.2 is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
      Missing Dependency: libORBitCosNaming.so.0 is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
      where can i get these rpms , such exact named rpm is not googling with its exact name , is there any alternate to solve that issue.
      libORBitutil.so.0
      ORBit
      libgdk_imlib.so.1
      imlib
      libORBit.so.0
      libIIOP.so.0
      libpng.so.2
      libORBitCosNaming.so.0
        • 1. Re: Post Installation check for 12.1.1
          Helios-GunesEROL
          Hi;

          First check from OEL DVD, i belive you should find it there. If you can not please check
          rpm for OEL 5.5
          rpm for OEL 5.5

          Regard
          Helios
          • 2. Re: Post Installation check for 12.1.1
            Dude!
            I think the easiest solution would be to setup Oracle public yum according to: http://public-yum.oracle.com/

            Installing packages using yum should outline and install package dependencies. You could try:
            # yum install gnome-libs*

            You can also query which package contains which file, e.g.:

            # yum provides libgdk_imlib
            -> imlib-1.9.15-11.el5.i386
            • 3. Re: Post Installation check for 12.1.1
              user13653962
              the required rpm gnome-libs-1.4.1.2.90-34.1.i386 is not in my DVD for oel 5 , i downloaded it , but when i install it , it gives me some others rpm dependencies which i am not getting after googling out a lot
              Missing Dependency: libORBitutil.so.0 is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
              Missing Dependency: ORBit is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
              Missing Dependency: libgdk_imlib.so.1 is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
              Missing Dependency: imlib is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
              Missing Dependency: libORBit.so.0 is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
              Missing Dependency: libIIOP.so.0 is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
              Missing Dependency: libpng.so.2 is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
              Missing Dependency: libORBitCosNaming.so.0 is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
              the dependent rpms are
              libORBitutil.so.0
              ORBit
              libgdk_imlib.so.1
              imlib
              libORBit.so.0
              libIIOP.so.0
              libpng.so.2
              libORBitCosNaming.so.0
              my confusion is should i install exact match of dependent package like libORBitutil.so.0 or some differ more or less rpm will do like ORBit2-2.14.7-3.0.120asp.i386.rpm
              • 4. Re: Post Installation check for 12.1.1
                Helios-GunesEROL
                Hi;

                Please search as gnome-libs on your dvd if its not exist you can enable yum future.

                Pelase see:
                Re: Package install for oracle11gr2

                Regard
                Helios
                • 5. Re: Post Installation check for 12.1.1
                  user13653962
                  i have done the same which you have referred within link and got a new file repositry public file under /etc/yum.repos.d , after that i opened the file and changed enabled from 0 to 1 as per given instruction within this link.

                  [el5_u4_base]
                  name=Enterprise Linux $releasever U4 - $basearch - base
                  baseurl=http://public-yum.oracle.com/repo/EnterpriseLinux/EL5/4/base/$basearch/
                  gpgkey=http://public-yum.oracle.com/RPM-GPG-KEY-oracle-el5
                  gpgcheck=1
                  enabled=1



                  still installing gnome rpm is asking foe dependencies.
                  • 6. Re: Post Installation check for 12.1.1
                    Dude!
                    RPM will not use yum to fetch dependent packages. How are you trying to install the software? Did you try yum to install the software?
                    • 7. Re: Post Installation check for 12.1.1
                      Hussein Sawwan-Oracle
                      still installing gnome rpm is asking foe dependencies.
                      What dependencies? Please post the list of packages here.

                      Have you tried to install those missing packages which are required for gnome?

                      Thanks,
                      Hussein
                      • 8. Re: Post Installation check for 12.1.1
                        user13653962
                        [oracle@test appshome]$ yum install gnome-libs-1.4.1.2.90-34.1.i386.rpm 
                        Loaded plugins: rhnplugin, security
                        *Note* Unbreakable Linux Network repositories are not listed below. You must run this command as root to access ULN repositories.
                        You need to be root to perform this command.
                        [oracle@test appshome]$ su - root
                        Password: 
                        [root@test ~]# 
                        [root@test ~]# cd /appshome/
                        [root@test appshome]# yum install gnome-libs-1.4.1.2.90-34.1.i386.rpm 
                        Loaded plugins: rhnplugin, security
                        This system is not registered with ULN.
                        ULN support will be disabled.
                        Setting up Install Process
                        Examining gnome-libs-1.4.1.2.90-34.1.i386.rpm: 1:gnome-libs-1.4.1.2.90-34.1.i386
                        Marking gnome-libs-1.4.1.2.90-34.1.i386.rpm to be installed
                        Resolving Dependencies
                        --> Running transaction check
                        ---> Package gnome-libs.i386 1:1.4.1.2.90-34.1 set to be updated
                        *--> Processing Dependency: imlib for package: gnome-libs*
                        *--> Processing Dependency: libgdk_imlib.so.1 for package: gnome-libs*
                        *--> Processing Dependency: libpng.so.2 for package: gnome-libs*--> Finished Dependency Resolution
                        1:gnome-libs-1.4.1.2.90-34.1.i386 from /gnome-libs-1.4.1.2.90-34.1.i386 has depsolving problems
                          --> Missing Dependency: libgdk_imlib.so.1 is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
                        1:gnome-libs-1.4.1.2.90-34.1.i386 from /gnome-libs-1.4.1.2.90-34.1.i386 has depsolving problems
                          --> Missing Dependency: imlib is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
                        1:gnome-libs-1.4.1.2.90-34.1.i386 from /gnome-libs-1.4.1.2.90-34.1.i386 has depsolving problems
                          --> Missing Dependency: libpng.so.2 is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
                        Error: Missing Dependency: libgdk_imlib.so.1 is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
                        Error: Missing Dependency: libpng.so.2 is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
                        Error: Missing Dependency: imlib is needed by package 1:gnome-libs-1.4.1.2.90-34.1.i386 (/gnome-libs-1.4.1.2.90-34.1.i386)
                         You could try using --skip-broken to work around the problem
                         You could try running: package-cleanup --problems
                                                package-cleanup --dupes
                                                rpm -Va --nofiles --nodigest
                        The program package-cleanup is found in the yum-utils package.
                        • 9. Re: Post Installation check for 12.1.1
                          user13653962
                          Dude 的原文:
                          RPM will not use yum to fetch dependent packages. How are you trying to install the software? Did you try yum to install the software?
                          I have followed the given link by helios and followed as follows http://public-yum.oracle.com/

                          Oracle Linux 5
                          # cd /etc/yum.repos.d
                          # wget http://public-yum.oracle.com/public-yum-el5.repo

                          but still problem not resolved.

                          帖子经 user13653962编辑过
                          • 10. Re: Post Installation check for 12.1.1
                            user10232063
                            yum install gdbm-1.8.0-36.el6.i686
                            ln -s /usr/lib/libgdbm.so.2.0.0 /usr/lib/libdb.so.2

                            and everything links fine : )