This discussion is archived
11 Replies Latest reply: Feb 4, 2013 2:05 PM by beachw08 RSS

Cannot call commit when using distributed transactions Error

beachw08 Newbie
Currently Being Moderated
I have a bpel process that is connected to a DB adapter to select items from a table.
I have configured a data source with the name PCBPELDataSource and the jndi name is jdbc/pcBPEL.
I have also created a connection pool called eis/DB/pcbpel and under the properties I have jdbc/pcBPEL in the xADataSourceName field.
Then I updated the datasource deployment.

This program worked for me the first day I ran it. When I came back to work to test it is now giving me this error every time I test it.

Exception [TOPLINK-4002] (Oracle TopLink - 11g Release 1 ( (Build 110305)): oracle.toplink.exceptions.DatabaseException Internal Exception: java.sql.SQLException: Cannot call commit when using distributed transactions Error Code: 0

I don't know what to do, is there something I'm missing. Please Help.
If you need more of the stacktrace let me know.


  • Correct Answers - 10 points
  • Helpful Answers - 5 points