This discussion is archived
5 Replies Latest reply: Feb 5, 2013 12:32 AM by Deepu M RSS

OATS 12.2 - recording Oracle EBS Forms - difficulties with Java

v.eckardt Newbie
Currently Being Moderated
I did a fresh installation OATS 12.2 to get some of the new features and tried recently the EBS Forms recording.

I am identifying two related issues where I need your assistance.

Initially I had only one Java installed, the one coming with Oracle EBS 12.1, which is in my case 1.6.0_07 (32bit). Working with the EBS Application was ok, but no Forms recording happend, always only html steps in Open Script.

Then I additionally installed java 1.6.0_31 (32bit), and since then also the forms recording worked well, except two exceptions:

1) I am always asked to agree to run a lower java version, when I start EBS Forms.
Q: How Can I suppress this java security message?

2) When I playback my recording, after opening the Forms part, the playback waits for about 30 seconds until continuing, so my total script duration is quite too much.
Q: What can I do to avoid this internal delay?

-----------
Here is what I did already to overcome both issues (without success):
- removed / installed both java again + PC restart
- cleared java cache
- verified that no OpenScript diagnostic message appears negative
- tested the demo cases from Oracle EBS itself, exactly the same behavior.
- installed 1.6.0_38 java (32bit), same behavior as described
- I am on Win7 64bit, IE8
- think time is set to No-Delay
- Prefs>Playback>EBS/Forms> Suppress JRE Plug In Security Dialog = ticked (does not change anything)

Can you help?
Thanks
Volker

-----------
Update
-----------
The OATS OpenScript 12.2 comes with java 1.6.0.26. If I persuade the EBS to use the same as default (via /forms/server/appsweb.cfg), then the first issue goes obviously away (although the approach is probably not a good one).

But still, when using now always java 1.6.0.26, the completely unexpected wait time, my second issue, is still there.
The unexpected wait time is exactly in front of the first keyboard interaction into the Forms
(in my case when the command gets fired: InvokeSoftKey textField("@name='PROFILE_OPTIONS_PROFILE_OPTION_NAME_0'"))
And then 30 sec later, the playback runs as fast as expected through all forms fields.

Perhaps someone can guide what is the right approach?

Kr
Volker
  • 1. Re: OATS 12.2 - recording Oracle EBS Forms - difficulties with Java
    Deepu M Journeyer
    Currently Being Moderated
    Hi Eckardt,

    Select 'Force HTTP Recording' in OpenScript Preference, ie open OpenScript Preference, the expand Record node, then select Oracle EBS/Forms Load, Then check checkbox 'Force HTTP Recording' true.


    If it doesnt work try following:

    Dont install a new java version. Openscript comes along with java.

    Go to OracleATS intalled folder, open openscript, you can see some batch files there. Open 'UninstallBrowserHelpers.bat', after that open 'InstallBrowserHelpers.bat'. Then open 'HelperService' folder in openScript. Then inside 'bin' open 'UninstallHelperService.bat' and 'InstallHelperService.bat' one after another.

    Then try to record forms.

    See console whether jar files are been downloaded during recording of forms.



    Another solution is there, but not a correct procedure.

    If you have another machine with OATS working fine with forms, then go to run, type %temp%. Copy 3 folders - OpenScript_FormsFT, OpenScript_Applet, OatsTempRTCache and paste it to %temp% in your machine(machine in which forms are not get recorded)

    Regards,
    Deepu M

    Edited by: DeepuM on Jan 31, 2013 11:21 PM

    Edited by: DeepuM on Feb 1, 2013 1:10 AM
  • 2. Re: OATS 12.2 - recording Oracle EBS Forms - difficulties with Java
    v.eckardt Newbie
    Currently Being Moderated
    Hi Deepu M,

    thanks a lot for your replay.

    I have good and bad news, the good first:

    I did a complete reinstall, win7 64bit, and only OATS 12.2. In addition I have installed Java 6.0.26. The issue I had with the java error (my fist issue) is gone.

    But still the second, the 30 seconds wait time in front of each Forms playback, is there and is quite annoying.

    Regarding your ideas:

    a) "Force HTTP Recording" enabled, no change
    b) I did the four steps with UninstallBrowserHelpers etc. , and no change
    c) the step with the 'type %temp%' I can not perform because I do not have any PC where it works.

    Any other idea why such unexpected wait time in front of Forms Playback happens in any OATS script?
    (The form opens correctly, but the data entry is just not starting immediately, sadly it waits in my new environment even longer)

    Note: when I record a load test instead, it works very fast, no wait time.

    Kr
    Volker
  • 3. Re: OATS 12.2 - recording Oracle EBS Forms - difficulties with Java
    Deepu M Journeyer
    Currently Being Moderated
    If you run scripts from OTM, it will play more faster than from OpenScript. I'm also using OTM for script playback. Also specify a 'Thread.sleep(8000)' or 'delay(8000)' after +web.window(     "/web:window[@index='1' or @title='Oracle Applications R12']").waitForPage(null);+ .
    So script will get a delay to launch forms.

    I also faced the same issue when I used OTM for script playback. I think the reason is script will try to perform an action in forms after executing +web.window("/web:window[@index='1' or @title='Oracle Applications R12']").waitForPage(null);+ , but script will not be able to do it, so it will wait upto a delay mentioned in your OpenScript preference to do the same action. Above I mentioned 8 sec, if your machine taking more than 8 sec to launch forms then change it to 10 or 15.

    Regards,
    Deepu M
  • 4. Re: OATS 12.2 - recording Oracle EBS Forms - difficulties with Java
    v.eckardt Newbie
    Currently Being Moderated
    Hi Deepu M,

    yes, the idea with preferences was very helpful. I had 300/300/100, and changed to 30/10/10.

    Now, the playback starts nearly in time, 3-5 seconds delay - which is ok for a functional test.

    I have the impression that the "Forms Startup Timeout" is not a timeout, it's a delay itself. So it should be set to the still-ok-value for a start up.

    I really like to know if this is a feature in 12.2, any previous experience with versions such as 9.2 or 9.3?

    kr, Volker
  • 5. Re: OATS 12.2 - recording Oracle EBS Forms - difficulties with Java
    Deepu M Journeyer
    Currently Being Moderated
    Yes, but after 12.* release I worked completely in 12.* version. So I don't remember any features in 9.* versions. I think same features are available in 9.3 version.

    Regards,
    Deepu M

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points