3 Replies Latest reply: Feb 1, 2013 9:27 AM by AndyT_PA RSS

    EPMA Configure Database cause EPM System Configurator to crash

      This is an EPM distributed environment on Windows 2008 R2 system patched to 300 for all installed products. The system was all working fine until the DBAs needed to change passwords, for security reasons.

      The passwords for the Weblogic admin, the repository databases were all changed. We walked through the system configurations and changed all the passwords in all the right places and everything works, except for the EPM Architect Dimension Server. All other products launch and we can login and use them.

      For the EPM Architect Dimension Server, we are unable to update the database password. In the EPM System Configurator, when we choose to "Configure Database" for EPM Architect, we enter the connection information and click next, and the utility crashes stating an application error.

      The only error anywhere is in the configtool.log file which simply says:

      [2013-01-30T11:34:00.420-05:00] [EPMCFG] [TRACE] [EPMCFG-01758] [oracle.EPMCFG] [tid: 16] [ecid: 0000JmCJgspEwGIFmrADS31H2KhK000003,0] [SRC_CLASS: com.hyperion.config.wizard.impl.DBConnectionForm] DB type is Oracle
      [2013-01-30T11:34:00.420-05:00] [EPMCFG] [ERROR] [EPMCFG-01020] [oracle.EPMCFG] [tid: 16] [ecid: 0000JmCJgspEwGIFmrADS31H2KhK000003,0] [SRC_CLASS: com.hyperion.cis.config.Configurator] Error: [[
      java.lang.NoClassDefFoundError: com/hyperion/cis/ISMPWizardServices
           at java.lang.Class.forName0(Native Method)
           at java.lang.Class.forName(Class.java:247)
           at com.hyperion.cis.config.Configurator.loadClass(Configurator.java:172)
           at com.hyperion.cis.config.Configurator.loadProductDBConfigurators(Configurator.java:201)
           at com.hyperion.config.wizard.impl.DBWizardState$1.validate(DBWizardState.java:348)
           at com.hyperion.hit.wizard.Wizard$NextClass.run(Wizard.java:531)
           at java.lang.Thread.run(Thread.java:662)
      Caused by: java.lang.ClassNotFoundException: com.hyperion.cis.ISMPWizardServices
           at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
           at java.security.AccessController.doPrivileged(Native Method)
           at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
           at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
           at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
           ... 7 more

      [2013-01-30T11:34:00.420-05:00] [EPMCFG] [TRACE] [EPMCFG-01173] [oracle.EPMCFG] [tid: 16] [ecid: 0000JmCJgspEwGIFmrADS31H2KhK000003,0] [SRC_CLASS: com.hyperion.config.wizard.impl.DBWizardState] Default cluster has been found in the Registry: Performance Management Architect
      [2013-01-30T11:34:00.451-05:00] [EPMINS] [ERROR] [EPMINS-00001] [oracle.EPMINS] [tid: 16] [ecid: 0000JmCJgspEwGIFmrADS31H2KhK000003,0] [SRC_CLASS: com.hyperion.hit.wizard.Wizard] trace: Unexpected error:[[
           at com.hyperion.config.wizard.impl.DBWizardState$1.validate(DBWizardState.java:360)
           at com.hyperion.hit.wizard.Wizard$NextClass.run(Wizard.java:531)
           at java.lang.Thread.run(Thread.java:662)


      We un-installed and reinstalled ODAC, but it didn't make a difference. The schema user is not locked (confirmed through sql plus on the same machine as EPMA).
      The password did not get updated in the EPM product, since if we try to start the EPMA Server, it fails stating that the username/password is invalid.

      Any pointers will be helpful, since at this point EPM Architect is un-usable.