5 Replies Latest reply on Feb 1, 2013 4:49 PM by Steven Zorb

    Build Problem

    Steven Zorb

      I am having trouble building my application. When I make a change in the Model project and 'Run', Model is not built and the change does not make it into the executable. If I clean the Viewcontroller project or delete its classes directory then it forces the Model changes to be included in the make.

      If I try to clean the Model project or delete its classes directory I get the following when I try to 'Run' / build.

      Error: model/DataControls.dcx was not found in the project output directory.

      As a test, I created a fresh workspace. That application seems to be working fine. Thus, it must be a problem with my workspace.

      I tried to create a duplicate of my application to see if that would solve the problem.

      Per Timo Hahn's direction I created a new application. The app name is different but Model and ViewController have the same names and paths. I copied the src directories from the 'real' application to the new application paths. I did not copy the .jpr files. When I open the new app the Model project looks like the 'real' app. However the ViewController is missing my .jsf and my task flow .xml files.

      I need help to figure out what to clean, rebuild, make etc once the .src files have been copied.

      Thanks for your time, Steve
        • 1. Re: Build Problem
          1 person found this helpful
          • 2. Re: Build Problem
            Timo Hahn
            Steve, sorry to hear you still have not solved your problem.

            The view controller project consists of more folders you need to copy. You jsf files are located in the public_html folder. Then the is the adfmsrc folder holdings metadata of your pages.

            There may be other files, but start with these folders.

            • 3. Re: Build Problem
              Steven Zorb

              I read the thread mentioned in the prior post. It got me looking into my Model project. It is possible that I at some point accidentallyl created a a .jsf or a task flow in my Model project and the moved it to the ViewControl project.

              My Model project has a META-INF folder that contains adfm.xml file. That file has the line:

              <DataControlRegistry path="model/DataControls.dcx"/>

              DataControls.dcx does not exist and it is the one that the build says it cannot find when I clean the Model project and then try to build. I looked thru some example projects that I have and none of them have a META-INF folder in the Model project. Could this be the problem? What would happen if I removed the Model META-INF folder.

              Thanks a bunch, Steve
              • 4. Re: Build Problem
                Timo Hahn
                You model project might work again. A model project does not have a META-INF folder!
                If there are other artifacts from a view controller you should get rid of them too.

                Again, start a fresh workspace, create a model project and a view controller project add some pages (one at least) to it and run it. If it shows up, you have a valid workspace structure. Compare this structure with your other project!

                • 5. Re: Build Problem
                  Steven Zorb

                  I created a new ADF application, created a database connection, created a .jsf, pulled a table onto the page from data controlls. It runs fine, displays data properly. Naturally, its Model project has no META-INF folder.

                  I removed the META-INF folder from the Model project of my 'real' application. I was able to do a clean all and build and it works with no error! My Model project has no other 'unnatural' items. I will not forget this lesson learned.

                  Thank you to all that posted, Steve