This discussion is archived
2 Replies Latest reply: Feb 2, 2013 7:29 AM by Jim Smith RSS

What's the right JDK version for windows vista SP1

923806 Newbie
Currently Being Moderated
Hello guys,
I’m trying to install SQL Developer on my old Windows Vista SP1 but as soon as I run it I got a message: Cannot find a J2SE SDK installed at path C:\Program Files\Java\jre6
I was reading a post and this problem could be solved by installing the JDK. I went to the Java Archive Download website (http://www.oracle.com/technetwork/java/javasebusiness`/downloads/java-archive-downloads-javase6-419409.html) and I downloaded 3 versions but none of them are working. There’re tons of them and I really don’t know which one should be the one to be installed in order to get the SQL Developer working. Any chance someone can help me solve this issue?
These are the errors I got when I run the installers:
Jdk-6u26-windows-i586 – error: D: \Java JDK\jdk-6u26-windows-i586.exe is not a valid Win 32 application. Size of the file downloaded: 7140KB
Jdk-6u26-windows-x64 – error: The version of this file is not compatible with the version of Windows you’re running. Check your computer’s system information to see whether you need an x86 (32-bit) or x64(64-bit) version of the program, and then contact the software publisher. (I was quite careless downloading this version cause I know my computer is 32-bit or x86) size of the file downloaded: 69,043KB
Jdk-6u37-windows-i586 – error: D: \Java JDK\jdk-6u37-windows-i586.exe is not a valid Win 32 application sizeof the file downloaded: 67,756KB
Thanks loads

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points