This discussion is archived
1 Reply Latest reply: Feb 3, 2013 7:19 PM by 558116 RSS

Problem with ksplice offline packages

adarobin Newbie
Currently Being Moderated
I have had a ticket open with support for almost a week, but I can't seem to convince them the problem is not on my end. It appears to me that the packages that were put on ULN in the ol5_x86_64_ksplice repo that are dated 20130123 are not signed correctly. I already have this package (uptrack-updates-2.6.18-308.16.1.el5.x86_64-20121205-0) installed. When I attempt to update to the latest version (uptrack-updates-2.6.18-308.16.1.el5.x86_64-20130123-0) I receive the following message:
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 1e5e0159
ol5_ksplice/gpgkey | 1.4 kB 00:00


Public key for uptrack-updates-2.6.18-308.16.1.el5.x86_64-20130123-0.noarch.rpm is not installed



I have gone on to my ULN mirror server and have noticed that all of the uptrack-updates packages at least in this repo have the issue:
[adarobin@mirrors getPackage]$ rpm --checksig uptrack-updates-2.6.18-308.16.1.el5.x86_64-20130123-0.noarch.rpm
uptrack-updates-2.6.18-308.16.1.el5.x86_64-20130123-0.noarch.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#1e5e0159)
[adarobin@mirrors getPackage]$ rpm --checksig * | grep "NOT OK" | wc -l
34
[adarobin@mirrors getPackage]$ rpm --checksig * | grep "NOT OK" | grep -v 20130123 | wc -l
0
[adarobin@mirrors getPackage]$ rpm --checksig *20130123* | grep -v "NOT OK" | wc -l
0


If anyone on the ULN team is monitoring this forum could they please check it out and verify that I'm not going crazy? It would be much appreciated.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points