1 2 Previous Next 29 Replies Latest reply: Feb 6, 2013 3:14 AM by Neo-b Go to original post RSS
      • 15. Re: not able to connect to database using sqlplus
        Neo-b
        I exported my ORACLE_HOME as below and still facing the same issue:
        export ORACLE_HOME=my oracle home
        export ORACLE_SID=orcl
        sqlplus /  as sysdba
        SP2-1503: Unable to initialize Oracle call interface
        SP2-0152: ORACLE may not be functioning properly
        • 16. Re: not able to connect to database using sqlplus
          tmbeetz
          Hi,

          can you show the environment settings especially LD_LIBRARY_PATH, ORACLE_HOME, ORACLE_SID


          Best Regards thomas
          • 17. Re: not able to connect to database using sqlplus
            sb92075
            Neo-b wrote:
            I exported my ORACLE_HOME as below and still facing the same issue:
            export ORACLE_HOME=my oracle home
            export ORACLE_SID=orcl
            sqlplus /  as sysdba
            SP2-1503: Unable to initialize Oracle call interface
            SP2-0152: ORACLE may not be functioning properly
            01503,0, "Unable to initialize Oracle call interface\n"
            // *Cause:  Indicates a library used by SQL*Plus to communicate with
            //          the database failed to initialize correctly.
            // *Action: Check that the Oracle environment or registry entries are
            //          consistent and correct.  If using the SQL*Plus Instant Client
            //          make sure the SQL*Plus and Oracle libraries are from the
            //          same release. Make sure you have read access to the libraries.
            [oracle@localhost ~]$ oerr sp2 152
            00152,0, "ORACLE may not be functioning properly\n"
            // *Cause:  Unable to initialize a session to the Oracle instance.
            // *Action: Make a note of the message and the number, then contact
            //          the Database Administrator.
            when was last time this worked OK?
            What changed since then?
            • 18. Re: not able to connect to database using sqlplus
              Neo-b
              this was working okay two days ago.

              I think some colleagues were cleaning the server and not sure what files they cleaned!
              • 19. Re: not able to connect to database using sqlplus
                sb92075
                Neo-b wrote:
                this was working okay two days ago.

                I think some colleagues were cleaning the server and not sure what files they cleaned!
                post results of following OS commands

                id
                env | sort
                • 20. Re: not able to connect to database using sqlplus
                  Neo-b
                  below is the requetsed:
                  /data/oracle>id
                  uid=13(oracle) gid=201(oinstall) groups=202(dba)
                  /data/oracle>env | sort
                  AUTHSTATE=compat
                  A__z=! LOGNAME
                  DISPLAY=192.168.0.56:0.0
                  HOME=/data/oracle
                  LANG=C
                  LC__FASTMSG=true
                  LD_LIBRARY_PATH=/data/oracle/oracle/product/10.2.0/db_3/lib:/data/oracle/oracle/product/10.2.0/db_3/lib32:/data/oracle/oracle/product/10.2.0/db_3/lib:/usr/lib:/lib
                  LOCPATH=/usr/lib/nls/loc
                  LOGIN=oracle
                  LOGNAME=oracle
                  MAIL=/usr/spool/mail/oracle
                  MAILMSG=[YOU HAVE NEW MAIL]
                  NLSPATH=/usr/lib/nls/msg/%L/%N:/usr/lib/nls/msg/C/%N:/usr/lib/nls/msg/%L/%N.cat:/usr/lib/nls/msg/C/%N.cat
                  ODMDIR=/etc/objrepos
                  ORACLE_BASE=/data/oracle
                  ORACLE_HOME=/data/oracle/oracle/product/10.2.0/db_3
                  ORACLE_SID=orcl
                  ORACLE_TERM=vt100
                  PATH=/usr/vacpp/bin:/usr/vac/bin:/usr/bin:/etc:/usr/sbin:/usr/ucb:/data/oracle/bin:/usr/bin/X11:/sbin:.:/data/oracle/oracle/product/10.2.0/db_3/bin
                  PS1=$PWD>
                  PWD=/data/oracle
                  SHELL=/usr/bin/ksh
                  SHLIB_PATH=/data/oracle/oracle/product/10.2.0/db_3/lib32:/data/oracle/oracle/product/10.2.0/db_3/lib:/usr/lib:/lib
                  SSH_CLIENT=192.168.0.80 51506 22
                  SSH_CONNECTION=192.168.0.80 51506 192.168.0.15 22
                  SSH_TTY=/dev/pts/1
                  TERM=xterm
                  TZ=CST6CDT
                  USER=oracle
                  WSM_CGI_DIR=
                  WSM_DOC_DIR="/usr/websm/http/com.ibm.websm.http.server_1.0.0"
                  WSM_WS_CMD="startsrc -s http4websm"
                  _=/usr/bin/env
                  /data/oracle>
                  • 21. Re: not able to connect to database using sqlplus
                    sb92075
                    explain & describe existing architecture.

                    does any OS virtualization exist?

                    is system architecture 64 or 32 bit?

                    is Oracle software 64 or 32 bit?

                    is this system DB Server system?
                    • 22. Re: not able to connect to database using sqlplus
                      Neo-b
                      sb92075 wrote:
                      explain & describe existing architecture.

                      does any OS virtualization exist?
                      No
                      is system architecture 64 or 32 bit?
                      64 bit
                      is Oracle software 64 or 32 bit?
                      64 bit Oracle server
                      is this system DB Server system?
                      Application and database server
                      • 23. Re: not able to connect to database using sqlplus
                        sb92075
                        ORACLE_HOME=/data/oracle/oracle/product/10.2.0/db_3
                        what are db_2 & db_1 directories supporting?
                        • 24. Re: not able to connect to database using sqlplus
                          Neo-b
                          It is some old "not used" Oracle home
                          • 25. Re: not able to connect to database using sqlplus
                            823085
                            if someone corrupted your sqlplus file then you would have a bad time. You won't be able to fix it unless you resinstall everything.

                            The best way to verify this is to find a system where you can install sqlplus (from oracle instant client or relevant package) then test again.

                            by the way, you havent' answered whether you are able to connect to database with "sqlplus / as sysdba" when logged in as "oracle" user and with ORACLE_HOME, ORACLE_SID set?
                            • 26. Re: not able to connect to database using sqlplus
                              sb92075
                              SHLIB_PATH=/data/oracle/oracle/product/10.2.0/db_3/lib32
                              why does "lib32" exist above & in LD_LIBRARY_PATH?
                              • 27. Re: not able to connect to database using sqlplus
                                Neo-b
                                I do not know why this file exists.
                                i am not the one who installed this db home. but may be the 10g database version is 32 bit
                                how can I confirm that ?
                                • 28. Re: not able to connect to database using sqlplus
                                  bigdelboy
                                  From memory, which may be imperfect, recent AIX Oracle versions are 64 bit.

                                  In general the 64 bit shared libraries should be in the path before the 32 bit.

                                  Suggest you checkout where your environment variables are being set .... eg $HOME/.profile and try to discover if anything has been changed recently.
                                  • 29. Re: not able to connect to database using sqlplus
                                    Neo-b
                                    I reinstalled Oracle software
                                    1 2 Previous Next