This discussion is archived
3 Replies Latest reply: Feb 28, 2013 1:20 PM by Scott_Symonds RSS

WLS Forms and Reports - Reports not displaying

989243 Newbie
Currently Being Moderated
We have installed the WLS server basic, Forms and Reports on a Win2008 Box, 32 Bit version installed on 64Bit box, no problems during install.

Tweaked the configuration file for the forms web to call our customized forms, all that works fine - except we have to state the port in the URL?? Not sure why when I forced the default to the directory where the forms and reports are located.

We can run reports, but will not display. Error msg states: Page cannot be found - look in the URL and it is pointing to : http://XXX.XX.XX.XX/reports/rwservlet/getjobid22

There is no port identified in the URL. I can go to the Report status page and run the report from cache just fine, the difference being the port number is in the URL.

I know this is something simple, I am banging my head right now! Any ideas?
  • 1. Re: WLS Forms and Reports - Reports not displaying
    sharmela-Oracle Expert
    Currently Being Moderated
    Are you accessing the forms and reports pages directly via the weblogic managed server port or via the webcache default port ?
  • 2. Re: WLS Forms and Reports - Reports not displaying
    989243 Newbie
    Currently Being Moderated
    The Web Logic managed ports. The forms are doing fine, but I still have to put a port in the URL address: Example:

    http://xxx.xx.xx.xxx:9003/forms/frmservlet/?config=one

    without the port number it will not find the form.

    Thanks!
  • 3. Re: WLS Forms and Reports - Reports not displaying
    Scott_Symonds Explorer
    Currently Being Moderated
    When you installed Forms and Reports, did you also configure Oracle HTTP Server (OHS) during the configuration of Forms and Reports (running config.bat)?

    If you did configure it along with Forms and Reports, you can configure OHS to use the default HTTP port of 80. As you can use OHS to run Forms and Reports, this can be used to run forms and reports without using a port in the URL. Initially, OHS uses port 8888, but you can make a quick change in httpd.conf (the main configuration file for OHS) to use port 80:

    1. Go to %ORACLE_INSTANCE%\config\OHS\ohs1 and open up httpd.conf using a text editor such as Notepad or WordPad. (NOTE: It is strongly recommended to make a backup of this file.)
    2. Inside httpd.conf, look for the line "# OHS Listen Port". In the next line, there is a parameter "Listen 8888". This is the port which OHS uses.
    3. Comment out this line and add a new line below it: Listen 80
    4. Save and close the file.
    5. Open up Command Prompt and navigate to %ORACLE_INSTANCE%\bin.
    6. Restart the OHS server using OPMNCTL with this command: opmnctl restartproc ias-component=ohs1
    7. When finished, run "opmnctl status" to ensure that OHS (ohs1) is in the "Alive" state.

    After this, you may test running your forms and reports using http://xxx.xx.xx.xxx/forms/frmservlet/?config=one (or any config section you have configured). This should allow you to successfully run forms and reports without using a port.

    Thanks,
    Scott (PITSS)
    http://pitss.com/us

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points