This discussion is archived
2 Replies Latest reply: Feb 7, 2013 12:32 PM by 989061 RSS

Oracle Forms Installer detects incorrect platform

989061 Newbie
Currently Being Moderated
The Forms Installer is detecting our Red Hat Enterprise Linux 6.3 system as "redhat-Red" instead of "redhat-6" and is failing the prerequisite check.

Oddly, this is only happening on some of our Red Hat EL 6.3 systems.

The installer we are using is ofm_frmrpts_linux_11.1.2.1.0_64_disk1_1of1.zip

I am attempting to determine where the installer is getting the platform information.

I have ruled out the following sources:
/etc/*release (redhat-release, system-release, system-release-cpe)
`uname -a`
`uname -r`
`lsb_release`
`cat /proc/version`

All of the above sources yield identical strings on systems that are detected as "redhat-Red" versus systems detected as "redhat-6".

Is it a Java function? If so, where is Java getting the information? How can I correct the error?


I've resorted to editing the Disk1/stage/prereq/linux64/refhost.xml to manually change one of the approved platform versions from "6" to "Red" to fool the installer, but this seems like treating the symptoms when we'd prefer to treat the source of the problem.
  • 1. Re: Oracle Forms Installer detects incorrect platform
    Kishore Rout Journeyer
    Currently Being Moderated
    Hi,
    Your OS is 32 or 64 bit? 32 bit not supported.Only Red Hat Enterprise Linux 6 update 1+ is certified with forms 11.1.2.1. Please see the certification matrix attached below.
    http://docs.oracle.com/html/E18558_01/fusion_requirements.htm#BABJBCAI

    if you OS is Red Hat Enterprise Linux 6 update 1+(64 bit) please make sure all the OS related packages are installed which are required as Forms installation.
    http://docs.oracle.com/html/E18558_01/fusion_requirements.htm#BABCEFEA

    You can also check below url for prerequisite of forms installation.
    http://pitss.com/us/2012/10/09/oracle-weblogic-and-forms-11gr2-setup-prerequisites-for-linux/

    if this helps please mark.

    Regards,
    Kishore
  • 2. Re: Oracle Forms Installer detects incorrect platform
    989061 Newbie
    Currently Being Moderated
    Our OS is 64 bit.

    We are fully within the certification matrix, which is a feat unto itself.

    All required packages are installed.

    And the systems that are identified as "redhat-6" are virtually identically to the systems that are identified as "redhat-Red".

    Java is the one difference between them - we have had various levels of Java on the boxes. Java 7u9 to Java 7u13, specifically.


    Where specifically does the Oracle Installer grab the OS/platform information?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points